View Single Post
Old 01-03-2017, 07:18 PM   #2972 (permalink)
motorulf
EcoModding Lurker
 
motorulf's Avatar
 
Join Date: Dec 2016
Location: northern sweden
Posts: 33
Thanks: 17
Thanked 20 Times in 17 Posts
I managed to setup the throttle, i think.
The motor is turning, which is good
But it just keep revving up, which is scary.
I disconnect the battery an let it calm down for a while.

When moving throttle higher than the treshold for min_throttle, the motor starts turning, if i drop the throttle down again, to regen, the motor still revs up.
I have not tested how far this will go, but 5 secs of spinning up = 4 minutes of spinning down. So it is quite fast...
I have max-battery-amps and max-battery-amps-regen at 15A.
The max-motor-amps and max-motor-amps-regen at 25A.
The current-sensor-amps-per-volt at 200A. I also tried with different values but no difference.
My problem is this: i measure 65A on the battery cable. how is this possible?
I think this is limited only by the internal resistance of my little 6s lipo 8Ah.

So why does it want to accelerate out into space and leave me?
And why does it seem like i can not limit the current?

Also, i have tried run-pi-test and run-rotor-test wich both seem to do nothing. They dont even result in an error.

"Welcome to amateur hour, first up is motorulf..."

Last edited by motorulf; 01-03-2017 at 07:22 PM.. Reason: language
  Reply With Quote
The Following User Says Thank You to motorulf For This Useful Post:
MPaulHolmes (01-03-2017)