View Single Post
Old 03-14-2019, 07:54 PM   #3409 (permalink)
thingstodo
Master EcoModder
 
Join Date: Sep 2010
Location: Saskatoon, canada
Posts: 1,455

ChargE (not yet running) - '92 Mazda MX6 LX
90 day: 33.89 mpg (US)

Ford Prefect - '18 Ford F150 XLT XTR
Thanks: 740
Thanked 534 Times in 429 Posts
Quote:
Originally Posted by 59Morris View Post
It looks like I'm in the same position as the previous two posters. I believe everything is hooked up correctly. Using the "stream" command I have verified the throttle, temperature sensor and encoder are working as expected. When I "run-pi-test2" it does not drop to zero but stays very close to 512. Nothing I have tried so for has made the motor turn. No error messages on startup except the one that says its not really an error. Does anyone have any suggestions as to what I might have missed??
(I'm testing with a 50 volt battery pack)
Check out @jackbauer's post here

https://ecomodder.com/forum/showthre...tml#post590417

If the vector output is not being called, there should be no output.

Besides that, a while ago you needed to have your throttle between min-regen and min-throttle (I didn't look up the actual variable names - sorry). Not sure if that is a requirement any more.

I can look tonight and find a config that worked OK for my motor. It won't likely work well for yours, but it should output *SOMETHING*

My bet is on the vector output still commented out. Do you have MPLab X installed so you can compile? If not, perhaps send @MPaulholmes or @Jackbauer a PM. They can send you a new file to load into your controller.

I've never gotten this darned compiler to spit out an actual file without errors .. so I can't help with that.

PS - I'm running a rev 2 board and I think you are all at rev 3 or 4
__________________
In THEORY there is no difference between Theory and Practice
In PRACTICE there IS!

Last edited by thingstodo; 03-14-2019 at 07:54 PM.. Reason: PS
  Reply With Quote
The Following User Says Thank You to thingstodo For This Useful Post:
59Morris (03-14-2019)