EcoModder.com

EcoModder.com (https://ecomodder.com/forum/)
-   Instrumentation (https://ecomodder.com/forum/instrumentation.html)
-   -   Turbogauge won't connect (https://ecomodder.com/forum/showthread.php/turbogauge-wont-connect-36545.html)

Crashy 06-14-2018 03:26 AM

Turbogauge won't connect
 
Today I received my turbogauge and tried it in 3 different 2005 vehicles. Turned ignition on, connected the plug...unit lights up, scrolls through some protocols, makes some clicking noises and shuts down after about 15 seconds.

Any ideas?

oldtamiyaphile 06-17-2018 08:41 AM

Since NZ is a big JDM importer, they weren't all Japanese/JDM's were they? Many don't run OBD-II so universal gauges won't work.

Crashy 06-17-2018 08:58 AM

Jdm?
Yes probably 90% of our cars are jap export. Another guage did not work either.
But I thought obd2 was universal law? Why put the plug there!

oldtamiyaphile 06-17-2018 09:14 AM

Japanese Domestic Market.

OBD-2 is law in the US.
E-OBD is law in the EU.

AU/NZ has no such laws, and Japan uses there own standard (JIS something I guess). We take whatever they send us.

All use the same connector though...

California98Civic 06-17-2018 12:48 PM

Quote:

Originally Posted by oldtamiyaphile (Post 572216)
Japanese Domestic Market.

OBD-2 is law in the US.
E-OBD is law in the EU.

AU/NZ has no such laws, and Japan uses there own standard (JIS something I guess). We take whatever they send us.

All use the same connector though...

This seems like really good information. I checked the "65+ Efficiency Mods" list linked above and the instrumentation section could use info such as this. Maybe someone could create a thread on it and the other current instrumentation options would be useful.


All times are GMT -4. The time now is 03:54 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Content Relevant URLs by vBSEO 3.5.2
All content copyright EcoModder.com