View Single Post
Old 10-27-2010, 02:46 AM   #3908 (permalink)
The Toecutter
EcoModding Apprentice
The Toecutter's Avatar
Join Date: May 2010
Location: Ghettoville, USA
Posts: 187

Rebellion - '16 KMX Framekit Custom electric velomobile
Thanks: 82
Thanked 113 Times in 65 Posts
I'm thinking the Atmel is faulty(under the assumption that that plays a role in controlling the current limit and controller ramp function). The car seemed to have no ramp function at all. The FETs blew so fast in that 2 feet of travel that the in-car ammeter gauge didn't even register a spike in the current reading, and it was under very light throttle.

The Arduino used before it worked fine.

Perhaps the PCB board that snakub received just might be faulty... his is the only example I know of that had proper soldering, but still doesn't work. The vast majority of the ReVolts built seem to work fine. I wish we could solve this issue so that this truck could be back on the road. I would be extremely frustrated if I were in his position.
  Reply With Quote