View Single Post
Old 01-22-2011, 11:49 PM   #19 (permalink)
EcoModding Apprentice
Join Date: Jan 2011
Location: Australia
Posts: 179

Sonata97 - '97 Hyundai Sonata GL
90 day: 25.96 mpg (US)

Pulsar - '03 Nissan Pulsar ST
Team Nissan
90 day: 36.09 mpg (US)

Lancer - '04 Mitsubishi Lancer
90 day: 31.11 mpg (US)

Lancer 2.0 - '09 Mitsubishi Lancer
90 day: 27.1 mpg (US)
Thanks: 9
Thanked 16 Times in 13 Posts
I tried to connect and use an arduino library for serial output to some wireless gear I have.

The wireless gear is receiving and sending data fine.

The connection to the car is - Pin1 to Arduino TX.
Pin 10 tied to pin 12 (ground), and this also goes to the arduino for ground (i.e. 10 goes to 12, 12 goes to GND on arduino).

I then set code to loop 30000 times waiting for data to be available on the serial port, so, Serial.begin(160), then loop 30000 times to see if any data came through. None. I tried 160, 8192, 1953, 1960, 1920 - none of these gave out any data.

As a last effort, I added Serial.print(0x21), just before each of the loops, to see if I had to ask for the data, and at the arduino, connected a jumper between TX and RX.

Still nothing.

But I think the problem there is I was using Serial.print, instead of Serial.write

Assuming what I've noted above is correct, then there is no data stream on those baud rates (else I would have got something output).

I'll try serial.write later, in which case, the data must be requested, and not the stream that I'd like to have!

Any recommendations on what else I could try ?
  Reply With Quote