View Single Post
Old 03-01-2015, 06:36 AM   #1742 (permalink)
Join Date: Nov 2013
Location: Australia
Posts: 350
Thanks: 95
Thanked 214 Times in 151 Posts
Originally Posted by thingstodo View Post
ME labs programmer won't identify the chip. Doc states that it will program a dsPIC30F4011, but when I run 'identify target' I get an error message that it cannot read the chip ID. Help files and troubleshooting have no suggestions. Anyone have experience?
I received similar errors on a few of my BMS modules.
Unable to identify chip Id sort of thing.
They were either i had forgotten to tell the programmer to supply the VCC voltage for the chip. I was using the programmer to power the chip which is different to how you and Paul are doing it.
Or there was a solder issue which a quick reflow fixed.
Basically a no comms situation on the ICSP.

Now i am assuming Paul was able to get his pickit3 and cable to talk to the controller board before he sent it. So i would be guessing either, ICSP cable pinout incorrect, programmer incompatible or the chip to be programmed isn't being powered correctly.
You mentioned the +12 came loose during shipping. Maybe there was more damage to that connector/circuit. I would check the correct power is getting to the micro controller.

Have you tried (is your programmer capable of) supplying power to the chip to be programmed? So not powering the controller board at all and telling the programmer to supply power to the chip?

Other than that i would wait for the pickit3 to arrive. At least you will get a premade cable and a programmer the same as what the developer used so you can do a comparison between setups.

Paul, you are using a Pickit3 aren't you? Not sure why i thought you were but maybe it was mentioned somewhere. Or maybe it is just my dodgy memory taking me for another ride.

Last edited by Astro; 03-01-2015 at 06:40 AM.. Reason: Clarify assumption.
  Reply With Quote
The Following User Says Thank You to Astro For This Useful Post:
MPaulHolmes (03-04-2015)