View Single Post
Old 03-07-2015, 02:02 AM   #1750 (permalink)
thingstodo
Master EcoModder
 
Join Date: Sep 2010
Location: Saskatoon, canada
Posts: 1,488

Ford Prefect - '18 Ford F150 XLT XTR

Tess - '22 Tesla Y LR
Thanks: 749
Thanked 565 Times in 447 Posts
Quote:
Originally Posted by MPaulHolmes View Post
It may have to be erased before programming. I'm not sure though.
I think I had the 'erase before programming' checkbox checked .. but I'll do the explicit erase, then reprogram. That's step 1.

Quote:
It's a hex file that was made in mplab 8.83. I would guess that it shouldn't matter if it's programmed on mplab x though.
I found 8.83 in the mplab archive and downloaded the zip file. If the erase does not help, I'll try using 8.83. That's step 2. Do you have the version of the compiler you are using? (just in case that makes a difference somewhere down the line) Are there versions for the libraries?

Quote:
If you hit enter, it should show a message about the version. "AC controller version 0.1" or something.
So it waits for "enter" first. Good. I should not miss it if hyperterminal doesn't connect right away.

I pushed down the 3 pin connector, on the serial cable I built, onto the control board, harder and got one of the cables 'sort of' working. If I hit enter, some gibberish shows up on the screen. I tried Enter a few times, then changed speed. Perhaps it was coincidence, but I made it down to 9600 baud, n, 8, 1 and it began to echo my characters .. or most of them. The high bit was set on one or two characters (not consistent) so there were line-drawing characters mixed in. I tried changing parity but no joy there.

So I tried JUST 115,200 baud. After a couple of dozen tries at ENTER (with some squares as a response from the control board) the cursor returns to the beginning of the line. Typing in 'config' does not display anything on the terminal. But 'config' echoes. At that point, everything echoes but nothing else happens. But there are no parity errors or goofy characters echoed either.

I took my second cable (with tx and rx backward) and re-soldered it to match the first cable. The second cable is much shorter so maybe it will have less trouble? Not so far. The second cable does not work at all. I knew my soldering skills were RUSTY ... but I expected things to at least WORK.

Step 3 will be to use a USB to serial adapter, first cable then second cable.

I'll report back tomorrow.
  Reply With Quote