View Single Post
Old 06-10-2015, 12:36 AM   #1 (permalink)
thingstodo
Master EcoModder
 
Join Date: Sep 2010
Location: Saskatoon, canada
Posts: 1,455

ChargE (not yet running) - '92 Mazda MX6 LX
90 day: 33.89 mpg (US)

Ford Prefect - '18 Ford F150 XLT XTR
Thanks: 740
Thanked 534 Times in 429 Posts
500A controller troubleshooting II

I'm looking for some basic stuff .. I have already posted that I purchased another guy's project, re-soldered a fair chunk of the control board, and have powered it up.

I have a solid green LED and a solid Amber LED. On power up, with a serial connection to hyperterminal running I see this
Cougar OS controller firmware v1.11b
But when I type - no echo of the characters. From the code here
Open ReVolt/Software - EcoModder

it looks like there should be local echo if the controller is receiving characters ...

So I guess that's question 1. Why don't I see echo of characters?
hyperterm running on XP SP2, using a real serial port (not USB converter). This is the same port that I've used to communicate (with the same serial cable) to Paul's new Open source AC controller
19200 baud, 8 data bits, 1 stop bit, no flow control


I could live without the serial working .. so when I ramp up the throttle, there is no output (connected to a small blower). The blower works fine. I keep checking it to make sure. At about 25% throttle, the amber LED starts to flash. That's question 2. Can I figure out why the Amber is flashing without the serial working?


So I tried

rt-period 1000

No response, no data. So I don't think the controller is receiving.


So I read the 500A controller troubleshooting thread, and tried this http://ecomodder.com/forum/showthrea...tml#post482317 and got 0.0 mV at 0 throttle and 2.5 mV at full throttle. So I guess the PWM output is not responding.


I'm not sure where to go from there. But I expect that it's to a poor solder joint somewhere.

  Reply With Quote