View Single Post
Old 02-06-2016, 06:28 PM   #52 (permalink)
ksa8907
Master EcoModder
 
Join Date: May 2012
Location: Tampa, FL
Posts: 1,652

Volt, gas only - '12 Chevrolet Volt Premium
90 day: 38.02 mpg (US)

Volt, electric only - '12 Chevrolet Volt Premium
90 day: 132.26 mpg (US)

Yukon Denali Hybrid - '12 GMC Yukon Denali Hybrid
90 day: 21.48 mpg (US)
Thanks: 190
Thanked 387 Times in 279 Posts
Quote:
Originally Posted by 96CX View Post
I did make sure to find ATF+4 to put in it, so I'm safe there.

It has thrown a p1740 code a couple times now, but both those times were shortly after I was fiddling around with taking it in and out of O/D. I'm guessing that somehow something is stuck so that it won't come out of overdrive-- I was driving 55, pressed the "O/D Off" and I could hear the torque converter come out of lock, and then lock back up, but it didn't actually shift down into 3rd. I did that a few or eight times, and then next time I started it up there was a nice yellow Check Engine Light. I'm not going to be towing anything, so my plan is to just leave it in O/D permanently and hope the light doesn't flick back on. We'll see how it goes.

The plan for the van is to use it as a road-trip/campermobile, not as a tow rig, so I think this should be fine for now.
My parents used to use their '92 3500 to take a youth group across the country and always towed a uhaul trailer full of sound equipment. The third transmission they put in it was the transmission that was used for the cummins diesel. No problems after that. Just an fyi if you wind up in the situation of replacement options.
__________________




  Reply With Quote