EcoModder.com

EcoModder.com (https://ecomodder.com/forum/)
-   Open ReVolt: open source DC motor controller (https://ecomodder.com/forum/open-revolt-open-source-dc-motor-controller.html)
-   -   500A Controller troubleshooting (https://ecomodder.com/forum/showthread.php/500a-controller-troubleshooting-32077.html)

Lectrik 06-02-2015 04:58 PM

500A Controller troubleshooting
 
Hi all,

I hope someone can help.

I built my Cougar controller several years ago when I thought my car was closer to being ready. Boy was I wrong!!

It is finally in the car and it looks like it should work but I get no response from the throttle. I did some troubleshooting but getting nowhere.

LED's are on solid, I can watch with a multi meter as the capacitors go through the pre-charge. That takes less than 3 seconds. The contactor signal never happens so I wired a switch to close the contactor.

No throttle response.

So now I load RTD Explorer on my laptop that doesn't have an RS232 port. Got myself a USB serial adapter. So now I have no communication. Don't know if it is because the controller is now talking or the adapter is having configuration issues.

Short of finding someone with an old laptop with an RS232 port I would sure appreciate some ideas.

Thanks in advance.
John

apowers 06-02-2015 07:39 PM

Sometimes my USB adapter does not respond. I keep trying a different port till it does. That might not be your problem.

I would not try troubleshooting at pack voltage. Maybe just use a 12 volt battery.

The first thing I would is if there is a short between motor negative and battery negative. That would be bad.


I hope that helps some.

Then maybe see what is working on it.

Alvin

Lectrik 06-02-2015 08:21 PM

apowers

Thanks for your reply.

I did have it on my bench and testing with two 12 volt batteries. One for supply and one to simulate pack. Have an extra 5K pot and used it for throttle. I can adjust throttle voltage from zero to about 2.2 volts. With a meter across B- and M- I read about point 5 volts. I'll discharge the caps again and check continuity across those two points.

Thanks for the suggestion.

Lectrik 06-02-2015 08:25 PM

I forgot to add....

I did take the case off and nothing is visibly burnt and no bad smell. I can spin the motor up with a 12v battery.

apowers 06-02-2015 09:19 PM

Yes continuity is what I should have said. Did you spin the motor at 12 volts using the controller? If so then it should be working.

Did you get the RTD working?

I saw on the other forum someone had built some of the controllers for sale. They had said that if the mosfets are shorted on that the contactors would not close. I never knew this. That seems like a good feature.

Alvin

Lectrik 06-03-2015 03:47 PM

Hi Alvin,

I Didn't get as much accomplished as I wanted today. I was trying to find an old used laptop.

Stopped in one local computer shop and asked the guy if he had one with an RS232 port on it. His response was "I don't know what that is". Oh boy !

Anyway, I had not tried the controller and motor together with a 12 volt traction pack but I did today. Still no throttle response.

The motor spins with a 12 volt battery connected directly to it.

The good news is I have an open ( not shorted) between B- and M-. I do read 40 meg ohms briefly before it reads open between B+ and M-.

I have it back in the house and will connect it to my desktop again tomorrow and play with com ports again to see if I can get some communication going. Getting ready to head out for the evening.

Thanks for your help.

Lectrik 06-04-2015 03:19 PM

Progress
 
Baby steps today!

After playing with com ports in Windows device manager I am able to make a connection. Previously I was using the utility that came with my USB/Serial adapter.

I can type commands in command line (config, restart etc.) but there is no response. Throttle control also has no response.

Tried running boot loader but all was accomplished was tying up the com port and couldn't disconnect.

MPaulHolmes 06-05-2015 01:03 AM

How was the microcontroller programmed? Is it an atmega8 or atmega168? Was this a kit from me, or something else?

Lectrik 06-05-2015 09:05 AM

The processor is an atmega168. I did not do any programinig to it. I got the kit from you. I just assumed it was pre-programmed

Sent you a PM

thingstodo 06-05-2015 03:30 PM

Quote:

Originally Posted by Lectrik (Post 481866)
LED's are on solid, I can watch with a multi meter as the capacitors go through the pre-charge. That takes less than 3 seconds. The contactor signal never happens so I wired a switch to close the contactor.

No throttle response.

The serial port should be 19,200 baud, no parity, 8 data bits, 1 stop bit. When you power up there should be a message that includes the firmware revision. I didn't see that listed in your messages. Do you get that far?


All times are GMT -4. The time now is 12:31 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Content Relevant URLs by vBSEO 3.5.2
All content copyright EcoModder.com