EcoModder.com

EcoModder.com (https://ecomodder.com/forum/)
-   Off-Topic Tech (https://ecomodder.com/forum/off-topic-tech.html)
-   -   car trouble robbing gas (https://ecomodder.com/forum/showthread.php/car-trouble-robbing-gas-9253.html)

ratherbehiking 07-16-2009 05:08 PM

car trouble robbing gas
 
Ive been having some issues with my rodeo and I thought I would ask everyone if they could help figure out whats up.

Sometimes when I start my car the engine revs pretty high and then will drop back down to a normal idle. This has happend a few times in the past 2 months. last weekend I go to start my car and it starts but stalls right away, when I put my foot on the gas it stayed running but as soon as I let off it would stall again. The problem didnt happen agian the next day when I started it up but it agian idled really high and then dropped back down to a normal idle within 10 secs or so.

Any help would be amazing I am pretty mechanically inclined just dont know evenything about cars and dont want to just start replacing things that might not be causing the problem. I was thinking it was the throttle position sensor that is going bad?

Thanks agian

McTimson 07-16-2009 09:31 PM

I would check vacuum lines first, make sure they're all connected, and that none are cracked or anything. I think a bad crankshaft position sensor can also cause it to shut off, and probably a bunch of other sensors too.

Is the check engine light on?

ratherbehiking 07-17-2009 02:25 PM

no check engine light
 
Thanks for your input. The check engine light has never come on, which is kind of a pain.


All times are GMT -4. The time now is 12:36 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Content Relevant URLs by vBSEO 3.5.2
All content copyright EcoModder.com