EcoModder.com

EcoModder.com (https://ecomodder.com/forum/)
-   OpenGauge / MPGuino FE computer (https://ecomodder.com/forum/opengauge-mpguino-fe-computer.html)
-   -   Mpguino not fully starting, or locking up (https://ecomodder.com/forum/showthread.php/mpguino-not-fully-starting-locking-up-4761.html)

wagonman76 08-26-2008 02:18 PM

Mpguino not fully starting, or locking up
 
My mpguino started acting up lately. Yesterday it reset itself on the way to work, but I figured not a huge deal. This morning as I left, it wouldnt work and I reset it, then realized it had somehow lost all its settings. I reset the parameters and it worked fine on the way to work. At lunchtime I tried to reflash the program (even the original program before changing the cursor position though it shouldnt have made a difference) several times, but it just acts really weird. Sometimes it wants to restart itself several times. When it does stay running, sometimes it goes to the contrast screen, other times not. Try to push any buttons and either one button works then it locks up, or it is totally locked up. It says it always is a successful flash.

I took it apart and all the connections are good. I wonder if anything got corrupted in the firmware? If thats what it sounds like, how do I go about fixing it? Or any other ideas?

dcb 08-26-2008 02:30 PM

How are you powering it?

MazdaMatt 08-26-2008 02:33 PM

I haven't used the device, but I am a computer engineer and work with similar stuff regularly. Checking your connections is a good start, but remember that a hairline fracture in a solder joint may only show up in real-world usage. I would recommend touching up all the solder to see if that solves your issue. Successful flashing means that the firmware is there and good. I assume you've done "verify" to make sure it is there and good.

A sometimes-good test for solder cracks is to power up the board and twist it back and forth to see if it duplicates the original issue. If so, solder it all up and you should be good.

good luck.

I ought to build me one of these. They work on OBD1 cars, eh?

wagonman76 08-26-2008 03:06 PM

In the car I am powering it with a constant 12v from the memory wire of the radio, no jack, I soldered the wires direct to the jack pads on the back of the board. Ill have to check but theres a chance it might be closer to 14 volts when running.

On the bench I am powering it with the computer USB power.

I have all the boards mounted with soft rubber hose on the screws on both sides, to hopefully keep it from stressing joints.

One thing I noticed on the bench is the light on the board that normally flashes at a precise regular pace is now erratic and sometimes not even on at all.

I just went out and plugged it into the car. It went to the parameter setting screen, I went through the parameters, seemed to work ok. Didnt start the car or anything. On the bench I tried it at 10 or 20 times and it wouldnt run right at all.

Wonder if theres a voltage issue?

I havent done "verify". What does it do, just compare the flashed program with the original and make sure it is the same? This stuff is new to me so I havent messed with anything Im not familiar with.

dcb 08-26-2008 03:11 PM

I'm thinking a "brownout" issue is likely, given the history if the atmel flash. Is it more likely to "forget" immediately after trying to start the car perhaps?

MazdaMatt 08-26-2008 03:15 PM

Does hte issue occur on the bench AND in the car?

wagonman76 08-26-2008 03:26 PM

When it did it yesterday, it reset about 4-5 miles into the 25 mile trip, but didnt lose the parameters. I soldered everything really good but Ill have to check for loose wires anyway. No splice taps.

It worked great everyday since I built it and got the wires oriented properly, about 2 weeks ago. Till yesterday of course. This morning I didnt touch it when I got in the car, it appeared normal, it displayed yesterdays mpg. When I started the car, it didnt update, and thats when I realized it was locked up so I hit reset. It went to the parameters screen and the default parameters came up so I knew it was all cleared. I pulled over and reset them and it worked fine all the way to work.

On the bench is where it is unusable. I dont have a way to put pulses into it on the bench though. Im using the same computer and same usb cable that worked just great before.

Edit: Though it doesnt explain the reset while driving, it could explain the reset while starting. Which will probably be worse for the next 9 months as the mornings get colder here and the voltage drops while cranking.

When I get off work, Ill plug it in USB again and check the voltage at the 5v pin with a multimeter. I checked it last week when fiddling with the display on USB power and it was basically 5v right on, like 4.95 or so.

dcb 08-26-2008 04:01 PM

Sorry, this is going to take a little guesswork.

Please do measure the voltage on the arduino 5 volt pin when it is plugged into the USB.

MazdaMatt 08-26-2008 04:03 PM

dcb, are you still blocking my posts?

wagonman76 08-26-2008 06:26 PM

Ok this might be it, or at least the bench part.

On the bench, first plugging it in gives 4.95, but then after a couple seconds it drops to 4.78. Tried this several times, same values. And it still wont work on the bench.

In the car, it gives 5.01 regardless of whether or not the engine is running. Plugged it in and it seemed to work just fine. Ill have to check it on a cold morning and see what I get. But now I think about it, 9 volts input is technically still supposed to be ok, and if the car is below 9 volts the ECM wont work to let the car start anyway.

So maybe Ive got a bad USB jack or solder. Ill check it when I get home with a different cable and computer and see what happens, to see if it is the jack or not.

Maybe the incident yesterday was a hiccup in the car electrical system.


All times are GMT -4. The time now is 02:12 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Content Relevant URLs by vBSEO 3.5.2
All content copyright EcoModder.com