-   OpenGauge / MPGuino FE computer (
-   -   MPGuino rebooting and freezing also... Power issue? (

tygertec 07-22-2009 07:32 PM

MPGuino rebooting and freezing also... Power issue?
I've browsed the many fine posts relating to the MPGuino locking up but still haven't found an answer yet.

Here's a brief history of the problem:

A mechanically-minded friend helped me install it in my 1990 Toyota Corolla 5 speed. (We also installed a tach and a vacuum gauge.)

We tapped the injector wire, ran a wire from the combination meter's VSS port, tapped an always-on 12v+ wire from either the stereo or the clock memory (can't remember which) and added a bolt to the firewall and ground both the MPGuino and the tach to it. All of these wires run to an RJ11 box so that I can easily plug and unplug the MPGuino if necessary.

We fired it up and configured the values (injectors for my 1990 Corolla seem to be in the ballpark of 322620341 usec/gal if you have the same injectors) and it worked great.

BUT... when doing EOC or turning the engine off/on, it would often reboot and lose my MPG info (especially when turning it off for some reason).

So, I tried running a wire directly from the battery (but kept the initial ground) and now its even worse! It reboots constantly while the car is on, totally loses all memory, and finally freezes and I have to leave it unplugged for a while. Also, the VSS doesn't even seem to register on the unit anymore. Curiously, as long as the car is OFF, the unit will run indefinitely. I tried running it with both the VSS and/or the INJ cables unplugged to see if they were the culprit, but it still misbehaves with just the power input.

I'm not sure what the problem is. Do I need to install some kind of car-based UPS to clean up the 12V power? I know a car's electrical system can very greatly in its output.

Thanks a lot and I hope my post makes sense. :o

PS: I'm not too good under the hood but I love FE had SG envy and so the MPGuino was a dream come true for me. :p A big THANKS to all the effort that went into producing it!

McTimson 07-22-2009 07:55 PM

Do you have the pre-assembled version from dcb, or the kit version, that you assemble and solder yourself?

Are you sure that each wire is connected to the right spot? Like, are you sure the VSS and +12V lines aren't switched, or anything like that?

tygertec 07-22-2009 08:56 PM

Thanks for getting back with me. :-)

Its the pre-assembled version from dcb, version 0.82

I thought I checked the wiring many times, but that's a good idea. However, if the unit +12V line was plugged into the VSS or the INJ line, would it have power with the car off, because with the car off, it seems to work perfectly.

McTimson 07-22-2009 09:10 PM

If they're plugged into the wrong spots, the unit can behave very weird. I would definitely at least verify that they're in the right spot. I had a kit version, and the instructions for the RJ11 wires didn't work out for me, they were in the wrong spots. I ended up having to follow the leads on the board itself, mainly using this image to figure out which one went where. I think it had something to do with using a weird standard RJ11 cable, so the colors were backwards.

Since it's the pre-assembled version, we can probably rule out anything being shorted out, but it wouldn't hurt to take a look at the unit and make sure that none of the metal leads are touching anything else on another part of the board.

tygertec 07-22-2009 09:20 PM

Thanks for the great suggestions! I'll definitely check that out tomorrow morning. I think I'll bring along a multimeter too and check the signals from the various wires to try and verify that they are what I think they are. Do you know what I should expect on the multimeter from the VSS and INJ wires if everything is working okay?

McTimson 07-22-2009 09:43 PM

The injector signal consists of pulses, as seen in this thread, so it would be hard to read with a multimeter, since the pulses happen so quickly.

I assume the VSS signal is similar, and the pulses occur more frequently the faster the vehicle is going, but I'm not positive. So again, it would be difficult to read on a multimeter.

If you see the voltage varying on one of the wires, then it's probably the VSS or injector signal, since they're the only ones that should change. Both the +12V and GND signals should remain constant.

tygertec 07-23-2009 01:28 AM

Thanks a bunch for the input. I'm going to review the whole setup tomorrow and do a sanity check.

tygertec 07-23-2009 12:11 PM

Initial findings:

With the engine ON my 12V+ connection reads ~14.57V+ and the INJ signal is about the same. The VSS signal is reading in the millivolt range which I find kind of strange. Also, the MPGuino displays 0MPH. The only signal it registers is the INJ signal, and then the whole thing crashes.

I'm wondering if it could be a ground issue? Maybe it doesn't get along well with the tach? (The two have a common ground.) I might try running a new ground wire directly to the battery and see if that helps...

Also, I looked at the unit itself for possible signs of damage or bridged connections and couldn't find anything.

I made the floppy and RJ11 connectors myself using the supplied materials but just in case I'm going to pull a floppy connector off an old power supply and try that. *Sigh* :-)

tygertec 07-23-2009 03:34 PM


Hooked the 12V+ and ground wires directly to the floppy connector and plugged in the MPGuino. Intentionally left the INJ and VSS wires off. It worked fine until I turned the car on. Then it reboot and froze.

Is it possible that this little guy just isn't liking the 14.57V my alternator is putting out?

McTimson 07-23-2009 06:07 PM

I doubt that the 14.5V is the problem, there'd be a lot more reports of it not working if that were the case. The voltage regulator is designed to take anything over 5V, and output an even 5V for the entire board, and output the rest of the energy into heat.

A new ground couldn't hurt. Also, do you know if the VSS signal from the ECU is the same one that went to the speedometer? If it splits anywhere, then I would try tapping it right from the ECU.

All times are GMT -4. The time now is 04:11 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Content Relevant URLs by vBSEO 3.5.2
All content copyright