EcoModder.com

EcoModder.com (https://ecomodder.com/forum/)
-   Open ReVolt: open source DC motor controller (https://ecomodder.com/forum/open-revolt-open-source-dc-motor-controller.html)
-   -   Problem with Evnetics throttle position sensor and the 144V400A Open Revolt (https://ecomodder.com/forum/showthread.php/problem-evnetics-throttle-position-sensor-144v400a-open-revolt-30262.html)

Enault 10-17-2014 11:45 AM

Problem with Evnetics throttle position sensor and the 144V400A Open Revolt
 
Hi all,
This is my first post here. First, thanks for everyones contributions to developing this great controller! :thumbup:
Mine has worked well for about two years.
I used to have a Fourthgen pot box in my car. It wore out recently and I decided to go through the modifications necessary to use a Hall efect sensor.
Everything should be done. The RTExplorer shows a nice throttle graph. The graph stays at zero for the first few degrees and then starts to follow the movement.
So it seems to be working but there is a "throttle voltage fault" and the yellow led blinks.
The throttle I have now is an Evnetics (Soliton) OEM throttle position sensor ( i know..first the cheapest and then the bling)
I have tried different t-min-rc, t-max-rc and t-fault-rc settings.
According to wikipedia a throttle position sensor can be either Hall effect, induction or magneto resistive. I don't know which type this is, but the manual for the Soliton controllers states that the throttle input is 0 to 5 Volts which should be right for the Open Revolt.
I'm pretty sure I have the three throttle wires connected correctly.
Any suggestions how to solve this would be much appreciated!
Some info about the car at: enaultlio.tumblr.com (should update that a bit...)

MPaulHolmes 10-18-2014 12:49 AM

you can set throttle fault voltage through the serial port. I forgot the command, but I will check it either tonight or tomorrow morning.

today!
use:
t-fault-rc xxx
save


So, in your case, you could try:
t-fault-rc 5
save

You are going to need something really small since that throttle goes really close to zero.

Enault 10-18-2014 07:52 AM

Thanks Paul,
Tried t-fault-rc 5
No difference.
I measured the voltage between pin 5 (5V) where i have the red throttle wire, and pin 4 (throttle input) where I have the white wire. It reads 5v at zero throttle and 0 volts at full throttle. However the RTDexplorer graph displays correctly.
Shouldn't the throttle go from 0 to 5?
Are the wires connected wrong or did the firmware update somehow go wrong?:confused:
Edit: no, I guess that correct. Voltage difference between input and 5v is 5v when the input is 0v at 0 throttle. At full throttle the difference is 0v. Right?

MPaulHolmes 10-18-2014 10:23 AM

the throttle should go from 0v for 0 throttle to 5v for max throttle.

I'll check the code I sent you this morning.
type "config"

What shows up when you type that?

Enault 10-18-2014 10:44 AM

1 Attachment(s)
Attached a photo. The computer i'm using for settings is not online...
Not shown here, but it says also cougar OS firmware v.1.11b
T-fault-rc here is 0. I was just trying that out. Did try 5 as suggested before too.

MPaulHolmes 10-18-2014 11:02 AM

zero throttle must really be giving you 0 volts. that makes it not practical to check for a disconnected throttle by seeing if it goes to zero. because it goes to zero without being disconnected. we should dump the throttle fault. if its disconnected, the throttle will be 0, which is safe.

I forgot to update the 1.11b to 1.11c last time.

Enault 10-18-2014 11:25 AM

Ok. Makes sense. Another solution might be to try and calibrate the throttle mechanically. The sensor has oval bolt holes for mounting. That might enable turning the sensor so that it won't go to zero.
Trying that now...

MPaulHolmes 10-18-2014 11:34 AM

I made the changes, so you can use that version if you like too. I'm emailing the hex file now.

Enault 10-18-2014 12:21 PM

:) That's it. I turned the sensor and the fault is gone.
Thank you Paul. I did not understand the connection between the fault and the throttle voltage being totally at zero :o
Wife will be happy to have the car shelter back...for a while...before it gets cold and I claim it to keep the batterypack warm :rolleyes:


All times are GMT -4. The time now is 11:45 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Content Relevant URLs by vBSEO 3.5.2
All content copyright EcoModder.com