View Single Post
Old 10-17-2014, 11:45 AM   #1 (permalink)
EcoModding Lurker
Join Date: Oct 2014
Location: Turku, Finland
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
Problem with Evnetics throttle position sensor and the 144V400A Open Revolt

Hi all,
This is my first post here. First, thanks for everyones contributions to developing this great controller!
Mine has worked well for about two years.
I used to have a Fourthgen pot box in my car. It wore out recently and I decided to go through the modifications necessary to use a Hall efect sensor.
Everything should be done. The RTExplorer shows a nice throttle graph. The graph stays at zero for the first few degrees and then starts to follow the movement.
So it seems to be working but there is a "throttle voltage fault" and the yellow led blinks.
The throttle I have now is an Evnetics (Soliton) OEM throttle position sensor ( i know..first the cheapest and then the bling)
I have tried different t-min-rc, t-max-rc and t-fault-rc settings.
According to wikipedia a throttle position sensor can be either Hall effect, induction or magneto resistive. I don't know which type this is, but the manual for the Soliton controllers states that the throttle input is 0 to 5 Volts which should be right for the Open Revolt.
I'm pretty sure I have the three throttle wires connected correctly.
Any suggestions how to solve this would be much appreciated!
Some info about the car at: (should update that a bit...)

  Reply With Quote