View Single Post
Old 11-18-2014, 08:53 PM   #6931 (permalink)
MPaulHolmes
PaulH
 
MPaulHolmes's Avatar
 
Join Date: Feb 2008
Location: Maricopa, AZ (sort of. Actually outside of town)
Posts: 3,832

Michael's Electric Beetle - '71 Volkswagen Superbeetle 500000
Thanks: 1,368
Thanked 1,201 Times in 765 Posts
I ran into a similar problem with programming the AC controller. It turned out that the colorful ribbon cable wasn't allowing it to be programmed correctly. Too dang long. Once I switched to a 6 wire shielded cable, everything was OK. It did work the few times I tried it with yours, but maybe it's one of those hit-and-miss things. Sometimes works and sometimes doesn't. I actually just bought some shielded 6 wire cable. I could mail you some. I don't have any 5 or 6 pin connectors though. I'd need to order that. In the meantime, it's extremely annoying, but you could take the enclosure off, and plug the pickit 3 right in to the 6 prongs with no cable. That's much more reliable because there's no cable involved.

I'll still looking for what could be causing the problem. I haven't found anything yet. I'm going to send you a simplified hex file, which doesn't use the EEProm at all. Just your programmed settings hardwired in. You can try programming that onto the chip using the ribbon cable. Worst case, you may have to remove the stupid top and plug the pickit 3 right in. dang it!!!

edit: I just sent a new hex file that skips reading from the EEProm, and just loads a default value in. BEfore, it would read from the EEProm, and if there wasn't a valid setting, it would load a default. But who knows. Maybe there was some left over valid programmed values that were messed up. So, let's avoid that difficulty at the moment, and just load defaults that I know are good. I hope this works!!

__________________
kits and boards

Last edited by MPaulHolmes; 11-18-2014 at 09:09 PM..
  Reply With Quote