View Single Post
Old 05-16-2018, 03:43 PM   #165 (permalink)
California98Civic
Cyborg ECU
 
California98Civic's Avatar
 
Join Date: Mar 2011
Location: Coastal Southern California
Posts: 5,289

Black and Green - '98 Honda Civic DX Coupe
Team Honda
90 day: 59.78 mpg (US)

Black and Red - '00 Nashbar Custom built eBike
90 day: 3671.43 mpg (US)
Thanks: 1,893
Thanked 1,597 Times in 1,084 Posts
Quote:
Originally Posted by mpg_numbers_guy View Post
... My check engine light is on, and by scanning the error code it's pointing to the O2 sensor on bank 1. EDIT: Error code P0135 I think?? MPGs haven't dropped yet...in fact I made a HUGE new MPG record today - ...
So if that is the code, then your upstream (top) o2 sensor is not heating quickly enough or properly. If that is the code and the failure, then your MPGs should drop and badly because that is the sensor that feeds data for the ECU to set AFR. Without good, quick data and good heating, the AFR will run rich, probably in open loop. So if this is the proper code, then I think you have a mild--even intermittent--O2 failure, which is a prime candidate for cleaning the O2 and saving some bucks. Clear the code to shut of the CEL after you double check which one it is and record it. I would not be surprised if it does not come back right away. Then clean both sensors. That's my thoughts.
__________________


See my car's mod & maintenance thread and my electric bicycle's thread for ongoing projects. I will rebuild Black and Green over decades as parts die, until it becomes a different car of roughly the same shape and color. My minimum fuel economy goal is 55 mpg while averaging posted speed limits. I generally top 60 mpg. See also my Honda manual transmission specs thread.

  Reply With Quote