Go Back   EcoModder Forum > EcoModding > Off-Topic Tech
Register Now
 Register Now
 

Reply  Post New Thread
 
Submit Tools LinkBack Thread Tools
Old 10-06-2016, 01:17 PM   #11 (permalink)
EcoModding Lurker
 
Join Date: Apr 2011
Location: Lake Charles, LA
Posts: 12

RedVX92 - '92 honda civic vx
Thanks: 2
Thanked 3 Times in 3 Posts
ITs the fuel pump.
Mine did the same thing, and I replaced all that you did plus more, but no change.

When I tested the fuel pressure with autozone free fuel pressure test kit, and found the specs were below, I changed the pump, filter, and screen.
I changed the filter first and it raised it slightly, but when I replaced the pump it runs like a new car now.

Lifetime warranty $69 autozone for the pump only.


Last edited by BrickHouseVX; 10-06-2016 at 01:20 PM.. Reason: unfinished.
  Reply With Quote
The Following User Says Thank You to BrickHouseVX For This Useful Post:
Xist (10-07-2016)
Alt Today
Popular topics

Other popular topics in this forum...

   
Old 10-07-2016, 03:39 PM   #12 (permalink)
Not Doug
 
Xist's Avatar
 
Join Date: Jun 2012
Location: Show Low, AZ
Posts: 10,550

Chorizo - '00 Honda Civic HX, baby! :D
90 day: 35.35 mpg (US)

Mid-Life Crisis Fighter - '99 Honda Accord LX
90 day: 33.68 mpg (US)

Gramps - '04 Toyota Camry LE
90 day: 33.15 mpg (US)
Thanks: 6,965
Thanked 1,979 Times in 1,505 Posts
Did you clean the EGR, though? Better now than when you get a CEL.

  Reply With Quote
Reply  Post New Thread


Thread Tools




Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Content Relevant URLs by vBSEO 3.5.2
All content copyright EcoModder.com