Go Back   EcoModder Forum > EcoModding > Instrumentation
Register Now
 Register Now
 

Reply  Post New Thread
 
Submit Tools LinkBack Thread Tools
Old 03-04-2008, 10:34 PM   #1 (permalink)
Awesomeness personified
 
AndrewJ's Avatar
 
Join Date: Dec 2007
Location: Columbia, MO
Posts: 642

Harold - '94 Honda Civic CX
90 day: 54.51 mpg (US)

Margot - '08 Surly Big Dummy
Thanks: 0
Thanked 27 Times in 17 Posts
Send a message via AIM to AndrewJ
Help! SuperMID pics needed!!

So I have a bit of a problem. I seem to have most of the requisite parts to build a SuperMID. I also have no idea how they're actually supposed to go together to make a working SuperMID
I have a SuperMID kit, which is cheaper than paying Yoshi to make one for you, but it also (unfortunately) comes with no instructions. Oh, and all the diagrams on Yoshi's website are in Japanese. Not gonna help me out much...

So if anyone out there with a SuperMID could take some pictures of their unit that would be excellent!

Pictures I really need are as follows:

-How the screen connects to the "SuperMID" board (electrically connects, that is)
-Where are the buttons?
-What does the black box ("interface" board) look like?

Here's what I have so far:

Most of the major parts in various states of (dis)assembly as of today




Front and back of the "SuperMID" PCB





Front and back of the "Interface" PCB






And here are the pics that Yoshi provided, these appear to be of prototype boards though....










__________________
"I got 350 heads on a 305 engine. I get 10 miles to the gallon. I ain't got no good intentions." - The Drive By Truckers.

  Reply With Quote
Alt Today
Popular topics

Other popular topics in this forum...

   
Old 03-04-2008, 10:37 PM   #2 (permalink)
Dartmouth 2010
 
SVOboy's Avatar
 
Join Date: Nov 2007
Location: Hanover, NH
Posts: 6,427

Vegan Powa! - '91 Honda CRX DX
Team Honda
90 day: 66.52 mpg (US)
Thanks: 92
Thanked 113 Times in 82 Posts
Send a message via AIM to SVOboy Send a message via MSN to SVOboy Send a message via Yahoo to SVOboy
so far,
  Reply With Quote
Old 03-05-2008, 12:37 AM   #3 (permalink)
MP$
 
diesel_john's Avatar
 
Join Date: Jan 2008
Location: SW Ohio
Posts: 591
Thanks: 5
Thanked 15 Times in 12 Posts
Send a message via MSN to diesel_john
Smile

here's a flow chart didn't know if it would help


http://img223.imageshack.us/img223/1...menueng7of.jpg

http://forum.ecomodder.com/showthrea...light=supermid


some other possibly outdated stuff
Attached Thumbnails
Click image for larger version

Name:	M-1Beta2.JPG
Views:	45
Size:	47.9 KB
ID:	413   Click image for larger version

Name:	M-1_SCH01_S.JPG
Views:	45
Size:	36.9 KB
ID:	414   Click image for larger version

Name:	M-1_SCH02_S.JPG
Views:	39
Size:	38.9 KB
ID:	415  

Last edited by diesel_john; 03-05-2008 at 01:13 AM..
  Reply With Quote
Old 04-04-2008, 03:53 PM   #4 (permalink)
Awesomeness personified
 
AndrewJ's Avatar
 
Join Date: Dec 2007
Location: Columbia, MO
Posts: 642

Harold - '94 Honda Civic CX
90 day: 54.51 mpg (US)

Margot - '08 Surly Big Dummy
Thanks: 0
Thanked 27 Times in 17 Posts
Send a message via AIM to AndrewJ
So I just finished putting the SuperMID together last night. I got all the wires finished up in the car this morning and just finished up the SuperMID's maiden voyage.

I got the black box plugged in to the cars electrical system, no problems there.

Then I hook up the lan cable from the black box to the MID.

SUCCESS!!!!!!!!

Screen shows: SuperMID V1.4 Honda.... (I don't really remember, something like that though.)

And then the screen goes black. (not blank, black)



Press all the buttons. Nothing.

Unplug and re-connect the lan cable.

Screen shows two black lines (lines 1 and 3)



Anybody want to venture any guesses as to what's wrong with my MID? I'm pretty clueless at this point.
__________________
"I got 350 heads on a 305 engine. I get 10 miles to the gallon. I ain't got no good intentions." - The Drive By Truckers.

  Reply With Quote
Old 04-04-2008, 05:30 PM   #5 (permalink)
Master EcoModder
 
bhazard's Avatar
 
Join Date: Mar 2008
Location: Toledo, OH
Posts: 500

2012 Golf TDI - '12 Volkswagen Golf TDI
TEAM VW AUDI Group
90 day: 45.51 mpg (US)
Thanks: 6
Thanked 34 Times in 27 Posts
Where did you get this kit?
__________________
'05 Outback XT, 19 mpg

BP-turbo 93 Festiva (long gone)
1/4 mile - 12.50@111.5
Best MPG - 36.8
  Reply With Quote
Old 04-04-2008, 08:53 PM   #6 (permalink)
Awesomeness personified
 
AndrewJ's Avatar
 
Join Date: Dec 2007
Location: Columbia, MO
Posts: 642

Harold - '94 Honda Civic CX
90 day: 54.51 mpg (US)

Margot - '08 Surly Big Dummy
Thanks: 0
Thanked 27 Times in 17 Posts
Send a message via AIM to AndrewJ
I got it from Ben (SVOboy) who got it from Yoshi.
__________________
"I got 350 heads on a 305 engine. I get 10 miles to the gallon. I ain't got no good intentions." - The Drive By Truckers.

  Reply With Quote
Old 04-05-2008, 08:26 PM   #7 (permalink)
Awesomeness personified
 
AndrewJ's Avatar
 
Join Date: Dec 2007
Location: Columbia, MO
Posts: 642

Harold - '94 Honda Civic CX
90 day: 54.51 mpg (US)

Margot - '08 Surly Big Dummy
Thanks: 0
Thanked 27 Times in 17 Posts
Send a message via AIM to AndrewJ
Success!!!

So I finally got the SuperMID working today. Turns out it just needed to be reset, but the reset "button" wasn't working. So I just desoldered and removed it.

Since the reset button just shorts the +5v side of the main PCB to ground, something I quickly figured out I could accomplish with the judicious application of a screwdriver or key to short out said points.

Anyway, back to the main point...

It WORKS!!!!


kinda...

I'm getting a good vss signal to it, but the injector signal isn't registering. I've only tried the wire for injector #4.

Oh well, I'm getting closer by the day. One of these weeks I ought to have this thing up and running properly.
__________________
"I got 350 heads on a 305 engine. I get 10 miles to the gallon. I ain't got no good intentions." - The Drive By Truckers.

  Reply With Quote
Old 04-05-2008, 08:38 PM   #8 (permalink)
Awesomeness personified
 
AndrewJ's Avatar
 
Join Date: Dec 2007
Location: Columbia, MO
Posts: 642

Harold - '94 Honda Civic CX
90 day: 54.51 mpg (US)

Margot - '08 Surly Big Dummy
Thanks: 0
Thanked 27 Times in 17 Posts
Send a message via AIM to AndrewJ
For all you electronics folks...

Oh and one more thing.

On the injector leg of the interface board I had to go buy a transistor to replace one I lost.

I got a PN2907 transistor from Radioshack because they didn't have the A1015 that was supposed to come with the kit.

While the voltage and amperage are pretty close for these transistors, I'm worried that perhaps the PN2907 may not be as fast enough to effectively relay the fuel injector pulses. I've read that the A1015 is good for audio applications because of it's speed.

Any thoughts?

__________________
"I got 350 heads on a 305 engine. I get 10 miles to the gallon. I ain't got no good intentions." - The Drive By Truckers.

  Reply With Quote
Reply  Post New Thread


Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
SuperMID - Fuel Economy Display SVOboy Instrumentation 25 05-15-2015 09:16 PM
[CRXMPG Mailbag] SuperMID and VSS Issues with EF Civics SVOboy Instrumentation 0 02-03-2008 04:33 AM
[CRXMPG FAQ] SuperMID and 1990 Toyota Truck SVOboy Instrumentation 0 12-04-2007 03:51 PM



Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Content Relevant URLs by vBSEO 3.5.2
All content copyright EcoModder.com