Go Back   EcoModder Forum > EcoModding > Off-Topic Tech
Register Now
 Register Now
 

Reply  Post New Thread
 
Submit Tools LinkBack Thread Tools
Old 08-29-2009, 12:52 AM   #1 (permalink)
Moderate your Moderation.
 
Join Date: Nov 2008
Location: Troy, Pa.
Posts: 8,919

Pasta - '96 Volkswagen Passat TDi
90 day: 45.22 mpg (US)
Thanks: 1,369
Thanked 430 Times in 353 Posts
OBD2 Diagnostic Flow Chart

Anybody have one for a code P1640? I haven't been able to find one yet, and it's showing on the Saturn. I never checked the codes before I put the new engine in, so I dunno if it's old or not, but I reset it 2 times today, and it came back within seconds.

I'm thinking it's got something to do with the A/C circuit, though. I didn't plug that one A/C line coolant sensor back in, and for some reason, the A/C pump won't turn on, even with it plugged in. Everything else works... car idles funny, etc... but I wanna work on clearing these codes and such first, then if the other stuff doesn't clear up after a few miles on the car, when the PCM makes nice w/ the engine, then I'll try to figure out what's wrong beyond that.

Alternator is making alot of bearing noise, as well... gonna have to swap it out for the other one, and hope that one is quieter... then rebuild the noisy one.

__________________
"┐ʞɐǝɹɟ ɐ ǝɹ,noʎ uǝɥʍ 'ʇı ʇ,usı 'ʎlǝuol s,ʇı"

  Reply With Quote
Alt Today
Popular topics

Other popular topics in this forum...

   
Old 08-29-2009, 02:26 AM   #2 (permalink)
PokÚmoderator
 
cfg83's Avatar
 
Join Date: Dec 2007
Location: Southern California
Posts: 5,864

1999 Saturn SW2 - '99 Saturn SW2 Wagon
Team Saturn
90 day: 40.49 mpg (US)
Thanks: 439
Thanked 529 Times in 356 Posts
Christ -

Try these ...

Radiator cooling fans run continuously
Radiator cooling fans run continuously - SaturnFans Forums
Quote:
Yes tried unhooking the negative to the battery only to clear the codes (sometimes this works) have two codes P0481 (fan 2 control circuit) and P1640 (Driver 1 input voltage high). Unhooking the battery cleared the codes and the fan seemed to run longer and more often but after awhile both code lights (Service engine & Service enging soon) came on. If it is in the ECM can it be reprogrammed or repair? I hope it dont have to be replaced everything else runs GREAT.
2001 Saturn L-200 2.2 code P1640, P0481
2001 Saturn L-200 2.2 code P1640, P0481 - SaturnFans Forums
Quote:
The code reader says P1640 "Driver 1 input voltage high & P0481 Fan 2 control circuit. I have checked and replaced (not blown) 10 amp ingition 3 fuse, replaced Air conditioning relay with new.
CarloSW2
__________________

What's your EPA MPG? Go Here and find out!
American Solar Energy Society
  Reply With Quote
Old 08-29-2009, 02:31 AM   #3 (permalink)
Moderate your Moderation.
 
Join Date: Nov 2008
Location: Troy, Pa.
Posts: 8,919

Pasta - '96 Volkswagen Passat TDi
90 day: 45.22 mpg (US)
Thanks: 1,369
Thanked 430 Times in 353 Posts
I just read through some of the SF.com threads... I'm going to check/replace the ECTS and unplug the cruise module to see if either is causing the 1640. There are only 3 or 4 things in the 1640's circuit, and the two lights work fine in the POST before starting.

It's the "wrench" light that's on. Stupid GM techs and their dry humor... "GoodWrench Service", so there's a Service light w/ a Wrench there. Go figure.

Also - the trip/odometer doesn't light up w/ the lights on. It's LCD... I assume there is a backlight that I will need to replace, and if so, I'm not worried about it. IF it's a worse problem, again, I'm not worried about it unless it's causing another issue.

__________________
"┐ʞɐǝɹɟ ɐ ǝɹ,noʎ uǝɥʍ 'ʇı ʇ,usı 'ʎlǝuol s,ʇı"

  Reply With Quote
Reply  Post New Thread


Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Increasing EGR flow for better mileage Daox EcoModding Central 232 01-26-2015 11:43 AM
Active Flow Control trebuchet03 Aerodynamics 14 04-07-2012 03:02 PM
How to get instant fuel consumption from Megasquirt TELVM Instrumentation 11 08-29-2011 03:47 PM
The Mechanism Behind Flow Separation LostCause Aerodynamics 46 07-15-2010 08:38 AM
air flow sensor instead of injector signal? modmonster OpenGauge / MPGuino FE computer 2 09-11-2008 07:59 PM



Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Content Relevant URLs by vBSEO 3.5.2
All content copyright EcoModder.com