Go Back   EcoModder Forum > EcoModding > Instrumentation > OpenGauge / MPGuino FE computer
Register Now
 Register Now
 

Reply  Post New Thread
 
Submit Tools LinkBack Thread Tools
Old 12-15-2009, 05:59 PM   #1 (permalink)
EcoModding Lurker
 
Join Date: Dec 2009
Location: Canberra
Posts: 11
Thanks: 1
Thanked 4 Times in 3 Posts
Injector opening delay

Hi,

I've built a similar gauge for my '99 Nissan Pulsar (which I think is Almera or Altima or something like that in the USA) after being impressed by the MPGuino when it got mentioned on hackaday. My hardware is similar but totally different software.

My question applies to the OpenGauge/MPGuino as well as my thing. Has anyone actually measured the opening and closing delay of a fuel injector? How do we know it's ~500uS? If the opening time is because of the physical movement of the valve, wouldn't there also be a similar closing delay?

Thanks. -Simon

  Reply With Quote
Alt Today
Popular topics

Other popular topics in this forum...

   
Old 12-15-2009, 06:08 PM   #2 (permalink)
dcb
needs more cowbell
 
dcb's Avatar
 
Join Date: Feb 2008
Location:
Posts: 5,032

pimp mobile - '81 suzuki gs 250 t
90 day: 96.29 mpg (US)

schnitzel - '01 Volkswagen Golf TDI
90 day: 53.56 mpg (US)
Thanks: 156
Thanked 264 Times in 207 Posts
It is an approximation, the opening takes longer than the closing, and is also dependent on vehicle voltage. But it is measured in terms of consistency between refills at the pump (factoring in refill technique of course). My saturn comes in within 1% consistently, your mileage may vary.

There was a proposal, assuming that your tank refill is accurate, that by keeping track of the number of injector pulses for the tank in addition to the open time , and keeping track of the actual refill amounts. That over several tanks you can find a value for injdelay and microsecondspergallon that best fit all the refills.

Of course if your refills are already within 1%, or off by a consistent percentage, then you might be like "why bother" But if not then this is something to investigate.
__________________
WINDMILLS DO NOT WORK THAT WAY!!!

Last edited by dcb; 12-15-2009 at 06:15 PM..
  Reply With Quote
The Following User Says Thank You to dcb For This Useful Post:
smonson (12-16-2009)
Old 12-15-2009, 06:31 PM   #3 (permalink)
EcoModding Lurker
 
Join Date: Dec 2009
Location: Canberra
Posts: 11
Thanks: 1
Thanked 4 Times in 3 Posts
That's a great idea! I haven't arrived at a value that works consistently for my car yet, although I haven't been keeping data for long yet. I did notice that my measured flow rate is higher than the published rate for my car - at least from what I can find out online. I should have 185cc/min injectors but my current setting is around 210cc/min. That was one of the things that prompted me to wonder about the opening delay.

I doubt my tank refill is very accurate (being a small car with a small tank). I think more information is the answer here. I am actually keeping track of the number of injector pulses in my software anyway to measure the RPM, so I just need to display that number on a separate screen. I wish it was the weekend already...
  Reply With Quote
Old 12-16-2009, 06:21 AM   #4 (permalink)
EcoModding Lurker
 
Join Date: Dec 2009
Location: Canberra
Posts: 11
Thanks: 1
Thanked 4 Times in 3 Posts
Here's my setup, for interest's sake. Everything looks better in black.
  Reply With Quote
The Following User Says Thank You to smonson For This Useful Post:
TomO (12-16-2009)
Old 12-16-2009, 12:04 PM   #5 (permalink)
That VX guy!
 
TomO's Avatar
 
Join Date: Nov 2007
Location: Mini Soda
Posts: 824

Odie2 - '04 Subaru Impreza WRX Wagon
90 day: 20.5 mpg (US)
Thanks: 74
Thanked 75 Times in 49 Posts
Send a message via AIM to TomO Send a message via Yahoo to TomO
That looks like it belongs there, smonson, very nice!
__________________

  Reply With Quote
Old 12-22-2009, 03:16 PM   #6 (permalink)
EcoModding Lurker
 
Join Date: Jul 2008
Location: Finland
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by smonson View Post
Hi,

Has anyone actually measured the opening and closing delay of a fuel injector? How do we know it's ~500uS? If the opening time is because of the physical movement of the valve, wouldn't there also be a similar closing delay?

Thanks. -Simon
VPV-Motorracing Electronics- Bosch Injectors

I was looking for the delays from Google one year ago. I have found only this link.

SIEMENS-DECA 006 injectors

Flow
2.5 bar 550ml/min
6 bar 860ml/min
Opening delay: 1.14ms at 14V
Closing delay: 0.85ms at 6 bar

Total delay would be 0.29 ms. 6 bar is quite high fuel pressure. Closing delay must depend of fuel pressure.
  Reply With Quote
Old 12-22-2009, 04:32 PM   #7 (permalink)
EcoModding Apprentice
 
Join Date: Oct 2009
Location: Portland OR
Posts: 183
Thanks: 1
Thanked 15 Times in 11 Posts
So then the question is,,,

If I lower the current but double the voltage will the injector open faster?

Hmm. I suddenly have a new experiment for the racecar.... Bwahahahahaha

Dave
__________________
If it has a motor its worth playing with.......
  Reply With Quote
Old 12-22-2009, 09:18 PM   #8 (permalink)
EcoModding Lurker
 
Join Date: Dec 2009
Location: Canberra
Posts: 11
Thanks: 1
Thanked 4 Times in 3 Posts
That's interesting - a difference of about 0.21ms from what dcb measured on his car. But these ones look like high-performance parts to me. Perhaps that is why. I wish car manufacturers weren't so secretive about everything, it really makes projects like this difficult.
  Reply With Quote
Old 12-22-2009, 09:26 PM   #9 (permalink)
dcb
needs more cowbell
 
dcb's Avatar
 
Join Date: Feb 2008
Location:
Posts: 5,032

pimp mobile - '81 suzuki gs 250 t
90 day: 96.29 mpg (US)

schnitzel - '01 Volkswagen Golf TDI
90 day: 53.56 mpg (US)
Thanks: 156
Thanked 264 Times in 207 Posts
I didn't "measure" it directly, I added it in and the pump numbers corroborated it. I'm sure it could be refined, but to what end? I would suggest a review of the calibration instructions for consistent refills, a lot easier than setting up a test rig to measure it for your specific vehicle, and you might just be overthinkin it. Or you might have peak and hold injectors too, dunno.

Mpguino calibration - EcoModder
__________________
WINDMILLS DO NOT WORK THAT WAY!!!
  Reply With Quote
Old 12-22-2009, 09:53 PM   #10 (permalink)
EcoModding Lurker
 
Join Date: Dec 2009
Location: Canberra
Posts: 11
Thanks: 1
Thanked 4 Times in 3 Posts
The accuracy of my setup varies depending on whether I'm commuting or travelling on the highway. I am just trying for more accuracy here. I'm not saying 500uS is wrong for your car.

Even though your system is quite accurate is all situations, mine isn't. There's a reason why the accuracy changes depending on the driving conditions and I'm just hoping to find out what that is. I don't have peak and hold injectors, though.

I'll be doing a 700km trip over Christmas and have added the ability to display an injector pulse counter on the screen, so that will provide some extra information to narrow down the source of the discrepancy, even if it's just to verify that the fuel injector opening time isn't a big deal.

  Reply With Quote
Reply  Post New Thread


Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
MPGuino for Audi rmccomiskie OpenGauge / MPGuino FE computer 40 05-22-2011 09:18 PM
Canceling out pumping losses of throttle governed engines greasemonkee EcoModding Central 60 08-03-2009 04:24 PM
Actual mpg vs % that mpguino is off wagonman76 Instrumentation 5 04-17-2009 07:41 PM



Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Content Relevant URLs by vBSEO 3.5.2
All content copyright EcoModder.com