Go Back   EcoModder Forum > EcoModding > Instrumentation
Register Now
 Register Now
 

Reply  Post New Thread
 
Submit Tools LinkBack Thread Tools
Old 01-10-2014, 03:12 PM   #11 (permalink)
EcoModding Lurker
 
Join Date: Feb 2013
Location: Sweden
Posts: 29

Abarth - '10 Fiat 500 Abarth
90 day: 33.4 mpg (US)

Yaris - '03 Toytota Yaris
90 day: 42.13 mpg (US)
Thanks: 0
Thanked 6 Times in 6 Posts
Finally got my UG yesterday and installed it in the car today. Apparently, the gauge does not support my my 2000 Suzuki Swift, or the Swift is not equipped with more than some Suzuki diagnostic ODB2 port layout.

A real bummer! Ironically this piece of equipment that was going to save me some money, actually ended up costing more than it can repay! Well, theres a new car arriving at the end of next week, hopefully that one will work!

__________________




  Reply With Quote
Alt Today
Popular topics

Other popular topics in this forum...

   
Old 01-10-2014, 06:08 PM   #12 (permalink)
Smeghead
 
Join Date: Oct 2009
Location: South Central AK
Posts: 933

escort - '99 ford escort sport
90 day: 42.38 mpg (US)

scoobaru - '02 Subaru Forester s
90 day: 28.65 mpg (US)
Thanks: 32
Thanked 145 Times in 97 Posts
I'm curious what failure mode you ended up with. I am considering requiring a swift/metro in the next few months and have a UG that I would like to use in it.
__________________

Learn from the mistakes of others, that way when you mess up you can do so in new and interesting ways.

One mile of road will take you one mile, one mile of runway can take you around the world.
  Reply With Quote
Old 01-11-2014, 01:20 AM   #13 (permalink)
EcoModding Lurker
 
Join Date: Feb 2013
Location: Sweden
Posts: 29

Abarth - '10 Fiat 500 Abarth
90 day: 33.4 mpg (US)

Yaris - '03 Toytota Yaris
90 day: 42.13 mpg (US)
Thanks: 0
Thanked 6 Times in 6 Posts
Quote:
Originally Posted by bestclimb View Post
I'm curious what failure mode you ended up with. I am considering requiring a swift/metro in the next few months and have a UG that I would like to use in it.
Basically the UG won't find the protocol and available gauges on startup.

Found this on Suzuki-forums, which is the exact problem I'm having...
"
The first thing that you need to determine is if your Swift is OBDII compliant - it may not be.

The easiest way to determine this is to check the J1962 connector under the dash and see which of the cavities are populated - if you have only 4,5,9 & 16 it's not OBDII compliant, but uses a proprietary SDL (Suzuki Data Link) protocol."
__________________




  Reply With Quote
The Following User Says Thank You to Pierrel For This Useful Post:
bestclimb (01-20-2014)
Old 01-11-2014, 12:03 PM   #14 (permalink)
Smeghead
 
Join Date: Oct 2009
Location: South Central AK
Posts: 933

escort - '99 ford escort sport
90 day: 42.38 mpg (US)

scoobaru - '02 Subaru Forester s
90 day: 28.65 mpg (US)
Thanks: 32
Thanked 145 Times in 97 Posts
I note you are in Sweden. do you know if it's a shortcoming specific to European market Suzuki or worldwide?
__________________

Learn from the mistakes of others, that way when you mess up you can do so in new and interesting ways.

One mile of road will take you one mile, one mile of runway can take you around the world.
  Reply With Quote
Old 01-12-2014, 02:51 AM   #15 (permalink)
EcoModding Lurker
 
Join Date: Feb 2013
Location: Sweden
Posts: 29

Abarth - '10 Fiat 500 Abarth
90 day: 33.4 mpg (US)

Yaris - '03 Toytota Yaris
90 day: 42.13 mpg (US)
Thanks: 0
Thanked 6 Times in 6 Posts
Quote:
Originally Posted by bestclimb View Post
I note you are in Sweden. do you know if it's a shortcoming specific to European market Suzuki or worldwide?
I know that other users on here that own a Suzuki Swift is using some sort of instrumentation. Like wmjinman, he's successfully using a scan gauge.

I do not know if its only a problem for all european cars, or if its the same with US cars. Sorry
__________________




  Reply With Quote
The Following User Says Thank You to Pierrel For This Useful Post:
bestclimb (01-20-2014)
Old 01-20-2014, 03:52 PM   #16 (permalink)
The PRC.
 
Join Date: Oct 2009
Location: Elsewhere.
Posts: 5,304
Thanks: 285
Thanked 535 Times in 384 Posts
Did you try the different connection protocols in the SG2 ? The auto-detect might not work.

__________________
[I]So long and thanks for all the fish.[/I]
  Reply With Quote
Reply  Post New Thread


Thread Tools




Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Content Relevant URLs by vBSEO 3.5.2
All content copyright EcoModder.com