Go Back   EcoModder Forum > AltModding > Alternative Transportation
Register Now
 Register Now
 

Reply  Post New Thread
 
Submit Tools LinkBack Thread Tools
Old 05-02-2012, 05:23 AM   #1 (permalink)
EcoModding Apprentice
 
BarelyAWake's Avatar
 
Join Date: Aug 2011
Location: Maine
Posts: 105
Thanks: 8
Thanked 54 Times in 38 Posts
Mongo, 48v 1000w 'Magic Pie' ehub on a Mongoose 'Snarl'

Well... I didn't think I'd ever be makin' an ebike thread - but here I am heh

A little background on this first I s'pose, I've been tinkerin' away on a suspended hybrid/tribrid tadpole trike on & off for about a year now: The Bent Zombie Tribrid Tadpole Trike & it occurred to me that it's electric drive was not only untested, but I was not terribly familiar with ebikes - the only one I'd ever had was years ago, a 12v SLA friction drive 'Zap' setup that was honestly a bit ridiculous, anemic to say the least it's woeful lack of power combined with it's incredibly limited range wasn't complemented by being a friction drive.

Fortunately, I held no grudge against the ebike concept because of it lol, even then I knew full well that wasn't a realistic system for anything other than the novelty factor.

Still, I figured I needed some time on a "real" ebike to see what I was getting into with the tribrid, I didn't have enough experience to know if it would be even worth the bother or what the problems may be - combined with the fact I needed a replacement commuter & winter beater I picked up a Mongoose Snarl mountain bike w/dual disc brakes to test out the electric drive (come winter it'll get an in-frame 2 stroke).

The bike itself is surprisingly good for the price ($250) with beautifully fat, nicely lapped weld beads, 100mm travel forks w/adjustable preload and ofc the disc brakes, which while generic - actually have a centering adjustment feature. The rims themselves are unsurprisingly just the typical single wall alloys w/14ga spokes - those will be replaced & I've ordered some low cost ($22ea) fatty double wall rims w/that in mind: Weinmann Disc Bull Rim 26 x 2.00 36 Hole Black along w/another pair of my favorite cheap ($17ea) tires: Cheng Shin C1218 street tire, 26x2.125 - which w/a harder compound than you'd expect w/semislicks & very thick tread area, have proven to be very puncture resistant, durable tires that handle great.

The only actual disappointments w/the Mongoose 'Snarl' (other than it's silly name ofc lol) is it's kickstand is about 3/4" too short even w/o the added weight of motorization (it's b'cause of the long travel forks) & the stock seat is by far the most uncomfortable thing I've ever sat on - I suspect a splitting maul just might be worse, but I'm not going to experiment w/that to see & I just stole the comfy sprung seat off my old Stokvis for now.

BTW, while mine is a 26" (for the hub motor & wheel I already had), the Mongoose 'Snarl' is also available in a 29" if you're interested, I did a quick test fit w/a in-frame 2 stroke and it seems to fit w/o issue (knowing it's aluminum w/an oversized down tube ofc), but I should mention that w/these forks, even the 26" is a somewhat tall bike & you may not want the 29" if you're "vertically challenged" - I'm a hair over 6' and even the 26" is taller than I'm used to.

Anyhoo, on to the ebike stuff heh - to mount the Golden Motor 'Magic Pie' 48v 1000w hub I had to open the drop outs just a hair for it's oversized axle... not so much even "widen" them but smooth them just a little to allow the flat-faced axle to slide up & in there (prevents torque rotation). The only problem w/that is as the axle is slightly larger the disc rotor doesn't quite go all the way up into the caliper anymore, it's about 1/16" short of the edge of the brake pads which will cause uneven wear w/a "lip" developing on the pad. I'll hafta fix that ofc... but I'm going to wait till I've my new rims built. I'd already made a rotor spacer for the tadpole as it's caliper (Avid BB5) was too close to the hub - coincidentally & very fortunately the spacer jus' happened to be perfect for the Mongoose's caliper too so I didn't hafta mess w/that anyway.

I then stole my poor Schwinn's rear rack, which I'd already modified w/vertical supports to the dropouts (it was a seatpost clamp only design), bolted it up to the Mongoose (just needed one spacer for a support to clear the rear caliper) with a set of M-Wave Double Day Tripper Bicycle Panniers ($25) for the 48V 15AH LiFePO4 battery packs to go into. The M-Wave panniers are lined with plastic panels so while they're not "collapsible" the panels serve to spread the weight evenly. I'd custom ordered the LiFePO4s to be split into two battery packs for the tadpole, which has worked out well for this too - I just can't see having 16lbs mounted to the top of the rack like I'd hafta if it was a single pack... even split into two & mounted lower the handling w/the weight back there is noticeably... different - not bad, but defo different. I s'pose I'll get used to it, I'm just glad it's not the 30+lbs of SLAs lol

Then it was jus' a matter of routing the wiring & handlebar controls & I was ready for the first test ride - which went well for about 45 minutes, then things started to go badly... very badly. I started loosing connections, the throttle, the main power leads & the hub (internal controller) started beeping error messages - sometimes, when it felt like it... and it just kept getting worse until I had nothing at all.

Knowing all the secondary connectors (throttle, cruise control etc) were cheesy, flimsy little bits with wiggly pins - I figured I had a loose connection somewhere & started my diagnostics. Interestingly, while those connectors are sad, pathetic lil things they weren't actually the problem... or problems as it turned out & thus began my three day headache of sorting out what the heck was going on.

First the main power plug had an intermittent failure on the negative pin (left plug in third pic) an easy fault to find & even easier to fix w/a new, far better connector, I'd already gotten a Delphi Weatherpack (weatherproof connector set) for the taddy's harness so I had a plug handy. The hub then worked fine... for about 5 minutes & then quit entirely again. This was a major setback as it obv wasn't the main power plug anymore I had to do continuity tests on the rest of the wiring - and the ends of those wires are ofc inside the hub, being a "spiffy" internal controller and all. This meant I had to pull the hub itself apart and that's no easy task as the side covers act as the armature's housing (centering & bearing mounts) and ofc it's sealed to protect the internals from the wet.

Searching around online I found only vague references to the disassembly procedure & what I found just couldn't be right - it was suggested that after removing all the fasteners from the cover to "pound on the other side of the axle with a mallet" and that "should free up the other side's cover" ...while I may be an ebike novice, I'm no stranger to electric motors or wheels & bearings for that matter and that recommendation filled my brain with horrid images of bunged up bearings, mangled C clips and other, even less pleasant suspicions. Fearing the worst, I just made my own puller - much like any gear/pulley remover it bolted into the brake rotor mounts and applied pressure to the axle, removing just the cover on the same side.

With the cover off finally many things became apparent - first, I would have done a number on the sealed bearings & retaining clips had I followed that "advice" & second, they were decidedly stingy with the solder... everywhere. Now able to do continuity tests I found that the main junction block (where all the separate wiring joins to become one cable, to then go into the axle) had faulty connections, problematic as it's a solid chunk of molded plastic (third pic, thing on the right). I tried for a while to gently cut it apart, but after succeeding only in cutting me apart I simply removed it and made my own (forth pic), after cleaning up the mess I made of my thumb ofc. Then I resoldered all the internal connections so I wouldn't hafta go in there again. While it isn't mine (I was too cranky for camera crap at that point), the fifth pic shows the internal controller, complete with it's shoddy soldering. Apparently this is common as every pic of the internal controller I found had similar issues, there's more examples here in the Mongo's photobucket album.



...so oddly, after replacing & resoldering all the connections except the ones I thought cheesy - everything tested out just fine... ok whatever, I can accept that lol, I've long distrusted electronics so I'll jus' chalk this up as another example why heh

I then reassembled everything again for another, hopefully more successful test run. I swapped out the lightweight tires the bike came with with the heavier duty tires the Schwinn was sporting, which turned out to be a mistake on my part as I hadn't noticed the sidewall damage from the Schwinn's maladjusted rim brakes & ended up with a wobble from the rear tire's broken belts. Oh well, just an excuse to get those spiffy new tires right?

Everything seemed to work well running it around the parking lot so I trusted it to get me to work, taking over the daily commute the now stripped Schwinn so faithfully ran for so long. Cruising a sustained 23, with a 25mph max (flat ground) and with decent acceleration I don't actually have to pedal to get started - I usually do anyway tho to lighten the load on the motor & battery reserve. After a coupla days of this and some playing around, I decided to do my weekly grocery run with it and that too went so well even laden down w/bachelor chow I decided to do a 15 mile lap just to see if that would make a dent in the seemingly endless battery reserve... and according to the (admittedly questionable) battery level lights on the throttle - it didn't, but there was no loss in power that I could see and as my lil 2A charger only took roughly two hours to top off the battery packs... I can only assume there was still quite a reserve. So this weekend I'm hoping to try twice that - to attempt a thirty mile trip, weather permitting ofc.




All in all I've really mixed feelings regarding the Golden Motor 'Magic Pie' setup... while it was a nightmare of shoddy soldering & cheesy connectors, with only very basic repairs it's turned out to be a decent hub drive that's very feature rich, the only other issue is the rim wasn't trued properly, but that's not unexpected w/any wheel purchase. Given it's relatively low cost ($240 for hub & wheel w/controller) I can't really recommend against it as it should be a really easy, simple ebike kit for the novice yet still having all the "bells and whistles" such as integrated lighting & horn, cruise control, true and adjustable regenerative braking, variable voltage compensation, anti theft, etc., etc., even reverse... not that such is needful with a bicycle lol

Thing is, I can't really recommend it either given the problems... I do suspect it would have been covered by the warranty had I tried it when I first got the thing and sent it back, Gary from Golden Motor Canada is reportedly good about such - but I didn't bother as I made the purchase about a year ago & I didn't feel like bothering with S&H and the wait times *shrug*

Anyway, here's a movie of some of my fifteen mile test run, just the four miles of the only bike path around here... I don't run the path with my stinky, loud & fast gas bikes, but I figured it'd be OK with the stealthy "clean" ebike lol, besides it was freezing cold & 6am - I figured there wasn't going to be many other riders, and there wasn't






  Reply With Quote
The Following 2 Users Say Thank You to BarelyAWake For This Useful Post:
ecomodded (09-29-2012), NeilBlanchard (05-02-2012)
Alt Today
Popular topics

Other popular topics in this forum...

   
Old 05-02-2012, 11:53 AM   #2 (permalink)
Master EcoModder
 
NeilBlanchard's Avatar
 
Join Date: May 2008
Location: Maynard, MA Eaarth
Posts: 7,822

Mica Blue - '05 Scion xA RS 2.0
Team Toyota
90 day: 42.48 mpg (US)

Forest - '15 Nissan Leaf S
Team Nissan
90 day: 156.46 mpg (US)

Number 7 - '15 VW e-Golf SEL
TEAM VW AUDI Group
90 day: 155.81 mpg (US)
Thanks: 3,290
Thanked 2,842 Times in 1,786 Posts
Are you intending to put a hub motor on the trike? And does the Golden motor have regenerative braking?
__________________
Sincerely, Neil

http://neilblanchard.blogspot.com/
  Reply With Quote
Old 05-03-2012, 05:29 AM   #3 (permalink)
EcoModding Apprentice
 
BarelyAWake's Avatar
 
Join Date: Aug 2011
Location: Maine
Posts: 105
Thanks: 8
Thanked 54 Times in 38 Posts
Yeppers... or rather I'm still considering it & thus the testing of the electric drive system on the Mongoose. I designed the taddy to be a hy/tribrid (49cc four stroke, electric hub & pedals) to maximize fuel efficiency - but it's as of yet still unclear if it's "worth it" with the extra weight & complexity. Here's an (outdated) pic;

w/more info here: http://ecomodder.com/forum/showthrea...ole-18414.html

& yes, the 'Pie has regenerative braking, switched levers & w/adjustable parameters (percentage of drag/charge) via USB/PC interface, which was one of the lures of this particular hub for the taddy application... but I haven't messed with it's settings yet as I seem to have misplaced the b'danged USB adapter

...which may actually be adversely affecting my evaluation as there are various preformance adjustments inaccessible otherwise, I gotta get on that lol
  Reply With Quote
Old 05-03-2012, 07:23 PM   #4 (permalink)
Master EcoModder
 
Join Date: Feb 2010
Location: Elmira, NY
Posts: 1,657
Thanks: 276
Thanked 289 Times in 244 Posts
Next trick is to add a windshield or fairing.
  Reply With Quote
Old 05-05-2012, 06:52 AM   #5 (permalink)
EcoModding Apprentice
 
BarelyAWake's Avatar
 
Join Date: Aug 2011
Location: Maine
Posts: 105
Thanks: 8
Thanked 54 Times in 38 Posts
A valid suggestion... but after much consideration I've decided for my usage, windshields & fairings are just too impractical & cumbersome TBH, particularly on this bicycle - which is serving only as a test platform for the ebike stuff anyway and will eventually be demoted to just another ICE powered winter beater/commuter.



More testing of some of some the taddy's components - this time lighting.

With any electric vehicle, power reserves are of paramount importance ofc, even a hybrid like the Zombrid as even though it's got an onboard charging system - every watt counts. Lighting can be a power hog, particularly if it's spiffy halogens so they're out of the question.

So after some shopping around I got a pair of LED MR16 Halogen replacement cool white spotlights (12V 4W/440 Lumen - 50 Watt Equivalent), one with a 30 beam angle (high beam) and one with a 60 for the low. Conveniently for the Mongoose, they just fit in the old headlight from my now stripped Schwinn, so I stuck the 30 beam one in there. Ofc not being 48v I have to use a DC to DC step down converter (60-48V in, 12V out) to power it and the LED taillight, which is simply a trim/marker light, commonly available at most auto parts stores - tho this too came off my ol' Schwinn.

After a coupla hours fiddling around with soldering connectors, more shrinkwrap & wire routing I was pleasantly surprised to find that it works really well! There's some peripheral efficiency loss w/e you use a converter, so the consumption wouldn't be as ideal as using 48v lights, but the loss is marginal - very marginal when you consider what 48v LEDs cost & their limited selection & availability lol

I should prolly point out that if you're looking for a low cost, reliable & effective lighting system for your own bike these 12v LED MR16 halogen replacement bulbs and the red trim/marker lights are commonplace & cheap (anywhere from 4-10 bucks ea), you'd just hafta come up w/your own 12v battery - a small SLA or better yet, a 12v ni-cd replacement power tool battery.

The MR16 is most commonly used for indoor track lighting BTW & while unusual for LEDs, the MR16 replacements are usually not polarity sensitive so you don't hafta worry if you wire it backwards;

  Reply With Quote
Old 05-08-2012, 07:51 AM   #6 (permalink)
EcoModding Apprentice
 
BarelyAWake's Avatar
 
Join Date: Aug 2011
Location: Maine
Posts: 105
Thanks: 8
Thanked 54 Times in 38 Posts
This past Sunday it was simply gorgeous out, so I hopped on the ebike & found some hilly, twisty back roads to go play on... I only ended up doing just under 20 miles this time, but given some of the terrain I encountered I was quite impressed - no battery fade & I found no hill that couldn't be conquered



Sadly, Mongo's down for about a week as I'm having a new wheelset built w/some decent aluminum double walled rims, stainless spokes & a set of fatty (2.125) semislicks...

...and I was jus' starting to really enjoy myself lol
  Reply With Quote
Old 05-08-2012, 09:04 AM   #7 (permalink)
Master EcoModder
 
NeilBlanchard's Avatar
 
Join Date: May 2008
Location: Maynard, MA Eaarth
Posts: 7,822

Mica Blue - '05 Scion xA RS 2.0
Team Toyota
90 day: 42.48 mpg (US)

Forest - '15 Nissan Leaf S
Team Nissan
90 day: 156.46 mpg (US)

Number 7 - '15 VW e-Golf SEL
TEAM VW AUDI Group
90 day: 155.81 mpg (US)
Thanks: 3,290
Thanked 2,842 Times in 1,786 Posts
You're flying! Do you have a speedometer?
__________________
Sincerely, Neil

http://neilblanchard.blogspot.com/
  Reply With Quote
Old 05-08-2012, 11:02 AM   #8 (permalink)
EcoModding Apprentice
 
Join Date: Jan 2008
Location: SF Bay Area
Posts: 150

Silver Bullet - '02 VW Golf TDi
Thanks: 5
Thanked 16 Times in 11 Posts
Awesome thread...thanks! Totally bookmarked. I wish every builder wrote and documented this well.

I do have a question since I'm considering doing a MP3/Ping build myself: how much does the MP3 kit really cost delivered to you here in the USA? I can see their prices on the web, and they have some links to shipping, but it all seems very obscure. Same with Ping.

Some "real world" numbers would be really appreciated...TIA.
__________________
Best tank ever: 72.1 mpg in February 2005, Seattle to S.F.
New personnal best 'all-city' tank June '08 ... 61.9 mpg!
Thanks to 'pulse-n-glide' technique.
  Reply With Quote
Old 05-09-2012, 04:57 AM   #9 (permalink)
EcoModding Apprentice
 
BarelyAWake's Avatar
 
Join Date: Aug 2011
Location: Maine
Posts: 105
Thanks: 8
Thanked 54 Times in 38 Posts
Neil - I've a lil Garmin Gecko 201 GPS I use in place of a speedometer... funny story actually, when I first got into motorizing bicycles I promptly went out & got myself a lil digital bicycle speedometer despite some occasional problems w/the application (calibration/EM interference/exponential error at greater speeds/failure), got home and was halfway through it's simple installation... and remembered I'd had the GPS for years and it was now just sitting in a drawer... oops So, I just gave the speedometer to a friend's kid instead.

Anyway to answer your question lol - TBH the feeling of speed is primarily because the camera is so close to the ground, I find the ebike impressive, but it's real speeds I've encountered so far are;

32mph max (downhill/vid)
25mph sustained (level ground/vid)
10mph (uphill - not in vid)

The GPS's oh so "professional" mount system BTW, electrical tape;





Thanks Stan, good to hear - I tend towards being a bit long-winded, but now I've an excuse right?

You're dead on about your concerns regarding the S&H fees, the MP seems to be saddled with a disproportionately high shipping cost, around a hundred dollars if I remember correctly. I thought at first it might have been some mysterious Canadian export/US import fee as I was getting mine through GM Canada... but shocked at the S&H I hunted around more - only to find all the domestic retailers had similar S&H charges, or even yet more.

I can only surmise they may be deferring some of their import costs to the customer as supplementary S&H, to keep the "retail price" competitive, or that they don't actually have the MPs in stock and just drop ship them from China w/the additional costs associated with such... I dunno TBH, it could be there's some tax, levy or fee associated with it - but that seems unlikely as I've not heard of such w/any other electric motors... while it is heavy (about 20lbs), it still seems a bit much for S&H alone.

I went ahead and got mine from GM Canada anyway as even with the S&H the MP is still very price competitive, but mostly because the owner of GM Canada is very active on Golden Motor's support forum, unlike any other retailer I found for the MP: goldenmotor.com - Index ... ofc as it's a support forum you're probably aware it's comprised mostly of the difficulties encountered and may not accurately reflect the product's overall satisfaction rate... or it might lol *shrug* hard to tell.

PingBattery on the other hand is a straight forward case - I don't remember exactly what I paid for S&H other than it was a marginal amount, significantly less than the MP although the battery packs I ordered are close to the same weight (16.5lbs) and all the way from China, they also got here promptly - a business week as I recall. I ordered direct from Ping simply because I wished a custom pack built, the 48v 15ah split into dual, separate packs to facilitate the installation on my taddy project (limited space). You might wish to consider that yourself as it makes it far easier to mount/provides better weight and balance as you can keep 'em low in panniers or w/e. Ping only charged an additional $10 for that customization, even though it included additional wiring for the BMS (battery management system)... or you could order from the ebay storefront PingBattery store eBay and get "free" S&H.

While the Magic Pie has mixed reviews, some love it & some hate it - it's apparent Ping is almost adored by the ebike community. I do know I would never get the batteries offered as part of an ebike "kit" as they're so critical, perhaps even more so that which motor you choose - and you'll get a LOT more for your money w/packs purchased separately.

I hope this helped, I know I was a little vague with the numbers you wished - but my purchases were about a year ago so even if I remembered clearly they may no longer be accurate... sorry 'bout that

Last edited by BarelyAWake; 05-09-2012 at 06:12 AM..
  Reply With Quote
Old 05-09-2012, 07:05 AM   #10 (permalink)
EcoModding Apprentice
 
Join Date: Jan 2008
Location: SF Bay Area
Posts: 150

Silver Bullet - '02 VW Golf TDi
Thanks: 5
Thanked 16 Times in 11 Posts
Quote:
Originally Posted by BarelyAWake View Post
Thanks Stan, good to hear - I tend towards being a bit long-winded, but now I've an excuse right?
Or at least an audience!

Quote:
You're dead on about your concerns regarding the S&H fees, the MP seems to be saddled with a disproportionately high shipping cost, around a hundred dollars if I remember correctly. I thought at first it might have been some mysterious Canadian export/US import fee as I was getting mine through GM Canada... but shocked at the S&H I hunted around more - only to find all the domestic retailers had similar S&H charges, or even yet more.

I can only surmise they may be deferring some of their import costs to the customer as supplementary S&H, to keep the "retail price" competitive, or that they don't actually have the MPs in stock and just drop ship them from China w/the additional costs associated with such... I dunno TBH, it could be there's some tax, levy or fee associated with it - but that seems unlikely as I've not heard of such w/any other electric motors... while it is heavy (about 20lbs), it still seems a bit much for S&H alone.

I went ahead and got mine from GM Canada anyway as even with the S&H the MP is still very price competitive, but mostly because the owner of GM Canada is very active on Golden Motor's support forum, unlike any other retailer I found for the MP: goldenmotor.com - Index ... ofc as it's a support forum you're probably aware it's comprised mostly of the difficulties encountered and may not accurately reflect the product's overall satisfaction rate... or it might lol *shrug* hard to tell.

PingBattery on the other hand is a straight forward case - I don't remember exactly what I paid for S&H other than it was a marginal amount, significantly less than the MP although the battery packs I ordered are close to the same weight (16.5lbs) and all the way from China, they also got here promptly - a business week as I recall. I ordered direct from Ping simply because I wished a custom pack built, the 48v 15ah split into dual, separate packs to facilitate the installation on my taddy project (limited space). You might wish to consider that yourself as it makes it far easier to mount/provides better weight and balance as you can keep 'em low in panniers or w/e. Ping only charged an additional $10 for that customization, even though it included additional wiring for the BMS (battery management system)... or you could order from the ebay storefront PingBattery store eBay and get "free" S&H.

While the Magic Pie has mixed reviews, some love it & some hate it - it's apparent Ping is almost adored by the ebike community. I do know I would never get the batteries offered as part of an ebike "kit" as they're so critical, perhaps even more so that which motor you choose - and you'll get a LOT more for your money w/packs purchased separately.

I hope this helped, I know I was a little vague with the numbers you wished - but my purchases were about a year ago so even if I remembered clearly they may no longer be accurate... sorry 'bout that
That was actually a big help...thanks! I've already been spending time over on the GM-Canada website and forum, and have seen all of Gary's MP3 vids. I need to do some more homework before plunking down money, but I think I'm going to do a bicycle rather than dive into the deep end with an electric car project. Thanks again!

__________________
Best tank ever: 72.1 mpg in February 2005, Seattle to S.F.
New personnal best 'all-city' tank June '08 ... 61.9 mpg!
Thanks to 'pulse-n-glide' technique.
  Reply With Quote
Reply  Post New Thread


Tags
ebike, golden motor, hub motor, lifepo4, magic pie

Thread Tools




Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Content Relevant URLs by vBSEO 3.5.2
All content copyright EcoModder.com