Go Back   EcoModder Forum > EcoModding > Instrumentation > OpenGauge / MPGuino FE computer
Register Now
 Register Now
 

Reply  Post New Thread
 
Submit Tools LinkBack Thread Tools
Old 09-20-2008, 04:26 PM   #1 (permalink)
Addicted
 
bbjsw10's Avatar
 
Join Date: Jul 2008
Location: Findlay,OH
Posts: 555

bbjsw10 - '91 Geo Metro Xfi
90 day: 51.06 mpg (US)
Thanks: 0
Thanked 10 Times in 7 Posts
MpGuino compatibilty issues

For those of you looking to build one if you have an alternator bypass switch. It will cause Guino to restart losing tank and current memory. Happened to me 3 times today, I am going to remove alternator switch. Or figure out how to fix it.

Next problem do not hook up a injector kill switch it will cause guino to lock up. Kill you ignition instead. This happened to me 4 times today before figuring out what was causing it to happen.

Just a few things to watch out for.

__________________
  Reply With Quote
Alt Today
Popular topics

Other popular topics in this forum...

   
Old 09-20-2008, 04:45 PM   #2 (permalink)
dcb
needs more cowbell
 
dcb's Avatar
 
Join Date: Feb 2008
Location:
Posts: 5,038

pimp mobile - '81 suzuki gs 250 t
90 day: 96.29 mpg (US)

schnitzel - '01 Volkswagen Golf TDI
90 day: 53.56 mpg (US)
Thanks: 157
Thanked 266 Times in 209 Posts
I am not sure where you are getting the guino power from, but you should be able to go straight to the battery and eliminate any chance of interference from the alternator kill switch.

And rest assured the guino does not lock up a metro with the cam signal kill switch. But an injector switch can "fool" it into giving false readings, or worse I imagine. I might try a 10k resistor across the switch/relay to hold the signal high but not give enough current to open the injector (assuming your switch is in-line with the injector). Obviously lots of creative ways to kill an engine I can't cover them all.

__________________
WINDMILLS DO NOT WORK THAT WAY!!!
  Reply With Quote
Old 09-20-2008, 07:36 PM   #3 (permalink)
Addicted
 
bbjsw10's Avatar
 
Join Date: Jul 2008
Location: Findlay,OH
Posts: 555

bbjsw10 - '91 Geo Metro Xfi
90 day: 51.06 mpg (US)
Thanks: 0
Thanked 10 Times in 7 Posts
Quote:
Originally Posted by dcb View Post
I am not sure where you are getting the guino power from, but you should be able to go straight to the battery and eliminate any chance of interference from the alternator kill switch.
I am going straight to battery power.Alt. kill causes enough of a voltage spike to reset unit. Maybe a capacitor on the battery feed would solve this. I am just going to remove my alt. kill and put in lighter battery.
__________________
  Reply With Quote
Old 09-20-2008, 07:54 PM   #4 (permalink)
EcoModding Apprentice
 
ptsmith24's Avatar
 
Join Date: Aug 2008
Location: Statesboro, GA
Posts: 177

El Camrino - '90 Toyota Camry LE
90 day: 32.47 mpg (US)
Thanks: 0
Thanked 0 Times in 0 Posts
Would a dedicated battery for 'guino work? A big enough battery should last at least a tankful (which is the point of having continuous power).
__________________
"It is foolish and wrong to mourn the men who died. Rather we should thank God that such men lived."
- General George S. Patton, Jr

  Reply With Quote
Old 09-20-2008, 08:22 PM   #5 (permalink)
dcb
needs more cowbell
 
dcb's Avatar
 
Join Date: Feb 2008
Location:
Posts: 5,038

pimp mobile - '81 suzuki gs 250 t
90 day: 96.29 mpg (US)

schnitzel - '01 Volkswagen Golf TDI
90 day: 53.56 mpg (US)
Thanks: 157
Thanked 266 Times in 209 Posts
BB, can you describe how you are going from 12 to 5 volts on your extremely handsome guino?
__________________
WINDMILLS DO NOT WORK THAT WAY!!!
  Reply With Quote
Old 09-20-2008, 08:36 PM   #6 (permalink)
Addicted
 
bbjsw10's Avatar
 
Join Date: Jul 2008
Location: Findlay,OH
Posts: 555

bbjsw10 - '91 Geo Metro Xfi
90 day: 51.06 mpg (US)
Thanks: 0
Thanked 10 Times in 7 Posts
Quote:
Originally Posted by dcb View Post
BB, can you describe how you are going from 12 to 5 volts on your extremely handsome guino?
I built just as schematic shows by using 7805. I take you saw the pictures of it, Thanks. I tested output of 7805 using my power supply and shows a good 5v supply.
__________________
  Reply With Quote
Old 09-20-2008, 09:26 PM   #7 (permalink)
dcb
needs more cowbell
 
dcb's Avatar
 
Join Date: Feb 2008
Location:
Posts: 5,038

pimp mobile - '81 suzuki gs 250 t
90 day: 96.29 mpg (US)

schnitzel - '01 Volkswagen Golf TDI
90 day: 53.56 mpg (US)
Thanks: 157
Thanked 266 Times in 209 Posts
If you have any larger capacitors laying around (or can salvage one from an old power supply or something) I might suggest putting it in parallel with the 330uf with some alligator leads as a test to see if that fixes it. The smallest one that does the job should minimize the wear and tear on that diode.

The metro alternator is a one wire? Can you expand on the alternator disconnect system a bit too?

Thx,
Dave.
__________________
WINDMILLS DO NOT WORK THAT WAY!!!
  Reply With Quote
Old 09-21-2008, 08:09 AM   #8 (permalink)
Addicted
 
bbjsw10's Avatar
 
Join Date: Jul 2008
Location: Findlay,OH
Posts: 555

bbjsw10 - '91 Geo Metro Xfi
90 day: 51.06 mpg (US)
Thanks: 0
Thanked 10 Times in 7 Posts
The alternator disconnect uses a 70 amp Potter Brumfield relay to break the output to the fuse box. The main feed (and field) wire it is like a 10 or 8 gauge wire.

I will try a 470uf I have laying here, I may have a couple larger ones can't find them right now.
__________________
  Reply With Quote
Old 09-23-2008, 06:07 PM   #9 (permalink)
Addicted
 
bbjsw10's Avatar
 
Join Date: Jul 2008
Location: Findlay,OH
Posts: 555

bbjsw10 - '91 Geo Metro Xfi
90 day: 51.06 mpg (US)
Thanks: 0
Thanked 10 Times in 7 Posts
Alright well I used the 470uf in parallel with the 300uf cap, fixed reset issue.

Switched to coil kill instead of injector kill, fixed lockup problem. (My 91 doesn't have a cam sensor so couldn't use your idea dcb.)

Now I have another issue, I tried some eoc, p&g today and that causes a reset. I think I am still getting a voltage drop that causes this issue. I am thinking about putting my old 1 farad cap from my car stereo days under the hood and hooking up to battery feed.

I figure if this is having issues with p&g what does it do to my ecu. It probably doesn't like the voltage drops/ spikes either. I figure it would be cheap insurance in my case to just help smooth the voltage to everything a little.

EDIT: Well I tried the 1 farad on the main lead from battery to fuse box, no help. I am going to go for drive again and see what I can figure out.
__________________

Last edited by bbjsw10; 09-23-2008 at 09:24 PM..
  Reply With Quote
Old 09-24-2008, 09:29 PM   #10 (permalink)
Addicted
 
bbjsw10's Avatar
 
Join Date: Jul 2008
Location: Findlay,OH
Posts: 555

bbjsw10 - '91 Geo Metro Xfi
90 day: 51.06 mpg (US)
Thanks: 0
Thanked 10 Times in 7 Posts
Please help!! Feeling lost.

Alright I am still having issues on this.

1. resets itself when EOC, but not everytime.
2. random lock up when it resets like in #1

Things I have done to correct this.
1. added a 470uf cap in parallel with the 330
2. put a 1 farad cap on main battery feed to underhood fuse box.
3. installed a 2ah 12v battery under dash that is hooked up to vehicle via a current limiting resistor and a diode. Thus eliminating voltage drop from vehicle, was trying to see if voltage is cause.

The other thing I have noticed is sometimes the cpu monitor shows random %'s like 775, 547, 180, etc. I have reloaded ver. 73 a couple times to make sure it copied correctly. Checked the shield I built multiple times. I am wondering is maybe the 7805 from radio shack is acting up, running out of ideas.

Could it be the vss delay being set at 3?

I love having it works great when driving normal, but I hate to drive normal now.

__________________
  Reply With Quote
Reply  Post New Thread


Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
MPGuino release one workspace dcb OpenGauge / MPGuino FE computer 1060 09-27-2016 10:56 PM
Just some quick info on Scangauge vs. MPGuino NoCO2 OpenGauge / MPGuino FE computer 4 06-01-2015 04:58 PM
MPGuino installation/setup: 1998 Geo Metro (Pontiac Firefly) MetroMPG OpenGauge / MPGuino FE computer 12 10-11-2009 03:29 PM
speed on mpguino fluctuates briansavka OpenGauge / MPGuino FE computer 1 08-01-2008 11:06 AM
Some suggestions and notes on the MPGuino SVOboy OpenGauge / MPGuino FE computer 4 08-01-2008 08:00 AM



Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Content Relevant URLs by vBSEO 3.5.2
All content copyright EcoModder.com