Go Back   EcoModder Forum > EcoModding > Fossil Fuel Free > Open ReVolt: open source DC motor controller
Register Now
 Register Now
 

Reply  Post New Thread
 
Submit Tools LinkBack Thread Tools
Old 04-03-2010, 10:57 PM   #3311 (permalink)
EcoModding Lurker
 
Join Date: Nov 2009
Location: Melbourne Australia
Posts: 23
Thanks: 4
Thanked 2 Times in 1 Post
Quote:
Originally Posted by adamj12b View Post
Yes, I believe that we will be doing another group buy for these. They will be slightly higher price. Maybe $10 more each max. Shipping to Australia wont be cheep though. It was $45 USD to ship them to Jack in Ireland. I would expect the same. I will add you to the list for 4 and give the total needed to be filled tomorrow. I got to got to bed now, I have a pounding headache. Goodnight!

-Adam
Thanks Adam, Its ok i've shipped items from the USA before. USPS is usually the cheapest, then UPS/FedEX. What is the exact model of the IGBT in the group buy?

hope you feel better!

  Reply With Quote
Alt Today
Popular topics

Other popular topics in this forum...

   
Old 04-04-2010, 07:10 AM   #3312 (permalink)
Master EcoModder
 
jackbauer's Avatar
 
Join Date: Sep 2009
Location: Ireland
Posts: 734
Thanks: 26
Thanked 296 Times in 168 Posts
More action :
Attached Thumbnails
Click image for larger version

Name:	con7.jpg
Views:	157
Size:	102.7 KB
ID:	5915   Click image for larger version

Name:	con8.jpg
Views:	141
Size:	90.3 KB
ID:	5916   Click image for larger version

Name:	con9.jpg
Views:	141
Size:	88.3 KB
ID:	5917   Click image for larger version

Name:	con10.jpg
Views:	137
Size:	89.3 KB
ID:	5918  
__________________
Now, Cole, when you shift the gear and that little needle on the ammeter goes into the red and reads 2000 Amps, that's bad.
www.evbmw.com
  Reply With Quote
Old 04-05-2010, 07:43 AM   #3313 (permalink)
Master EcoModder
 
jackbauer's Avatar
 
Join Date: Sep 2009
Location: Ireland
Posts: 734
Thanks: 26
Thanked 296 Times in 168 Posts
Up and running! I'm a bit concerned if the dc dc and drive circuit can handle the load of 4 devices. the top of the wave looks a little "bumpy" ........... Mabey the igbts have been reading too many peak oil books.
Attached Thumbnails
Click image for larger version

Name:	con11.jpg
Views:	146
Size:	122.0 KB
ID:	5919   Click image for larger version

Name:	con12.jpg
Views:	119
Size:	110.8 KB
ID:	5920   Click image for larger version

Name:	con13.jpg
Views:	114
Size:	102.4 KB
ID:	5921   Click image for larger version

Name:	ge1.jpg
Views:	116
Size:	122.4 KB
ID:	5922   Click image for larger version

Name:	ge2.jpg
Views:	88
Size:	117.3 KB
ID:	5923  

Click image for larger version

Name:	ge3.jpg
Views:	87
Size:	117.8 KB
ID:	5924   Click image for larger version

Name:	ge4.jpg
Views:	87
Size:	122.1 KB
ID:	5925  
__________________
Now, Cole, when you shift the gear and that little needle on the ammeter goes into the red and reads 2000 Amps, that's bad.
www.evbmw.com
  Reply With Quote
The Following User Says Thank You to jackbauer For This Useful Post:
bigh (04-05-2010)
Old 04-05-2010, 04:17 PM   #3314 (permalink)
Joe
 
Join Date: Feb 2009
Location: phx
Posts: 260
Thanks: 0
Thanked 41 Times in 34 Posts
Quote:
Originally Posted by jackbauer View Post
Up and running! I'm a bit concerned if the dc dc and drive circuit can handle the load of 4 devices.
sweet! it looks like 12V on the scope - is that the gate voltage using the original drive circuit on the control board? Any plans for a dedicated 15V "on" voltage with negative "off" voltage? I know adam has plans for something like that, but if you are using the original hardware, I'm curious how it works.

Also, looks like it's at 8khz - these IGBT's are rated up to 20khz, any plans to push it back to 16khz?

edit:
with regards to the waviness - it looks like the paths from driver to gate are significantly longer than before (though I don't know what your current IGBT setup looks like - maybe it's about the same?). But, I've read that keeping these paths short will reduce parasitic inductance that can lead to 'gate ringing'. The gate capacitance basically forms an LC oscillator with this inductance. I'd think you'd get a much higher frequency 'ring' though...
__________________
ReVolt AZ testing thread:

http://ecomodder.com/forum/showthrea...ting-9325.html

Last edited by jyanof; 04-05-2010 at 04:23 PM..
  Reply With Quote
Old 04-05-2010, 04:44 PM   #3315 (permalink)
Master EcoModder
 
jackbauer's Avatar
 
Join Date: Sep 2009
Location: Ireland
Posts: 734
Thanks: 26
Thanked 296 Times in 168 Posts
yep i'm running a 12v dc dc but i've ordered a 15v. Dont know why i got a 12v in the first place. Also the decoupling caps on the driver are wrong. .1uf instead of 4.7uf so i'll be changing that. Once i have these mods done i'll see what happens then try for 16khz.

I've no plans to introduce a negative gate drive at this time. If it ain't broke ....
__________________
Now, Cole, when you shift the gear and that little needle on the ammeter goes into the red and reads 2000 Amps, that's bad.
www.evbmw.com
  Reply With Quote
Old 04-05-2010, 06:07 PM   #3316 (permalink)
Master EcoModder
 
Join Date: Apr 2009
Location: Charlton MA, USA
Posts: 463

EVVette - '71 Chevy Corvette Coupe
Thanks: 31
Thanked 172 Times in 92 Posts
Quote:
Originally Posted by jyanof View Post
with regards to the waviness - it looks like the paths from driver to gate are significantly longer than before (though I don't know what your current IGBT setup looks like - maybe it's about the same?). But, I've read that keeping these paths short will reduce parasitic inductance that can lead to 'gate ringing'. The gate capacitance basically forms an LC oscillator with this inductance. I'd think you'd get a much higher frequency 'ring' though...
I talked to Fran today who recommended using powerex modules and he said that he has observed this ringing in his designs and its completely normal.

I cant wait to get the ones I have built into power stages for my controller now!!

-Adam
__________________
www.EVVette.com - 1971 Corvette Coupe Conversion to all Electric!
www.AdamBrunette.com - Machining, CNC, Robotics and Electronics.

You can download RTD Explorer for the Cougar controllers at www.EVVette.com
  Reply With Quote
Old 04-06-2010, 08:18 AM   #3317 (permalink)
Custom EV Builder...
 
Join Date: Jul 2009
Location: Ohio
Posts: 57
Thanks: 8
Thanked 1 Time in 1 Post
Quote:
Originally Posted by adamj12b View Post
I talked to Fran today who recommended using powerex modules and he said that he has observed this ringing in his designs and its completely normal.

I cant wait to get the ones I have built into power stages for my controller now!!

-Adam
I thought any kind of ringing in the gate circuit was bad? I was told that signal needs to be as clean as possible otherwise you can go up in smoke when under heavy load.
Keep in mind I know just enough about this to be dangerous.
  Reply With Quote
Old 04-08-2010, 10:33 AM   #3318 (permalink)
EcoModding Lurker
 
Join Date: Feb 2010
Location: East Europe>Bulgaria>Sofia
Posts: 23
Thanks: 3
Thanked 8 Times in 6 Posts
Finally i receive mine Altrax i purchase it before i met you guys and today i made one test on 24 volts Mine gas pedal was one small 4,7k trimer Have a lot to do and finally i hope to build one 144v 500-600 amp controller and put in car one powerfull motor. However it's nice to drive an electric car very quiet thing

Last edited by ludiagsm; 04-08-2010 at 10:49 AM..
  Reply With Quote
The Following User Says Thank You to ludiagsm For This Useful Post:
deodeo (03-26-2012)
Old 04-09-2010, 01:15 PM   #3319 (permalink)
EcoModding Lurker
 
Join Date: Oct 2009
Location: romania
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
nice job!
  Reply With Quote
Old 04-10-2010, 10:36 PM   #3320 (permalink)
PaulH
 
MPaulHolmes's Avatar
 
Join Date: Feb 2008
Location: Maricopa, AZ (sort of. Actually outside of town)
Posts: 3,831

Michael's Electric Beetle - '71 Volkswagen Superbeetle 500000
Thanks: 1,367
Thanked 1,115 Times in 730 Posts
OK! Houston we have a problem!

I have sent out about 10 of the LEM HAS 300-S (digikey sent me the wrong part, and I just now discovered this). You need the LEM HASS 300-S (HASS. NOT HAS). I'm going to email everybody that may have gotten the wrong sensor, but I'm posting pictures here for people to check. If you got the wrong sensor, I'll pay for shipping back to me, and then Digikey will reimburse me. Then they will send me the correct sensors, and I'll mail them to you:

This is picture 1 of the HAS 300-S (the wrong current sensor, that must be exchanged):


Here's picture 2 of the HAS 300-S (the wrong current sensor, that must be exchanged):


Here's a picture of the CORRECT current sensor. The LEM HASS 300-S:


Here's another picture of the CORRECT current sensor:


So, if your controller mysteriously isn't working, then this could be it! Hey Ben! I bet this is the problem!

__________________
kits and boards
  Reply With Quote
Reply  Post New Thread


Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Paul and Sabrina's Cheap 3 Phase Inverter (AC Controller) with Field Oriented Control MPaulHolmes Fossil Fuel Free 3471 06-01-2020 10:53 PM
Paul & Sabrina's Cheap EV Conversion MPaulHolmes Fossil Fuel Free 542 11-12-2016 09:09 PM
Three Dirt Cheap DIY Electric Cars - Part 5 SVOboy EcoModder Blog Discussion 0 12-12-2008 04:10 PM



Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Content Relevant URLs by vBSEO 3.5.2
All content copyright EcoModder.com