Go Back   EcoModder Forum > EcoModding > Instrumentation > OpenGauge / MPGuino FE computer
Register Now
 Register Now
 

Reply  Post New Thread
 
Submit Tools LinkBack Thread Tools
Old 01-01-2010, 05:02 AM   #1 (permalink)
in tents
 
dennyt's Avatar
 
Join Date: Dec 2009
Location: Seattle, WA, USA
Posts: 158

The Adventure Wagon - '94 Subaru Loyale Wagon 4x4
Subaru
90 day: 33.43 mpg (US)

Electro-Monkey - '11 Surly Karate Monkey BMC V2S Front Hub Motor
90 day: 694.1 mpg (US)
Thanks: 31
Thanked 30 Times in 22 Posts
Question Subaru Loyale - MPGuino Install

Howdy! I've been reading this forum for the last week, getting stoked on all kinds of mods. I just bought an MPGuino, it showed up in 2 days, I installed it tonight, and clearly I didn't pick the correct leads to tap into.

The unit displays just fine, but it isn't picking up VSS. I think I tapped into an unused VSS connector, but I just found on the Rostra site that I should tap into the YR coming from the speedo. Tomorrow...

Perhaps a bigger problem is that, in the custom screen, it displays 6.5 GH at idle, and the number decreases as I add engine load. Neither of these terminals showed 12V with the ignition on and the engine stopped, as in the instructions, so I just tapped into the RW on this schematic. Will switching over to the other lead to the injector fix things, or is this a peak-and-hold problem?


My car is a '94 Loyale Wagon, 5spd, non-turbo, SPFI.

Many Thanks,
-Denny

(Disclaimer - I'm a mechanical engineer, not a sparky. The vacuum gage went in tonight too, and works just fine )

__________________

Last edited by dennyt; 01-01-2010 at 05:25 PM.. Reason: not as much help needed...
  Reply With Quote
Alt Today
Popular topics

Other popular topics in this forum...

   
Old 01-01-2010, 05:19 AM   #2 (permalink)
in tents
 
dennyt's Avatar
 
Join Date: Dec 2009
Location: Seattle, WA, USA
Posts: 158

The Adventure Wagon - '94 Subaru Loyale Wagon 4x4
Subaru
90 day: 33.43 mpg (US)

Electro-Monkey - '11 Surly Karate Monkey BMC V2S Front Hub Motor
90 day: 694.1 mpg (US)
Thanks: 31
Thanked 30 Times in 22 Posts
Problem partially solved, I just found this post, and changing the Injector Trigger from 0 to 1 seems to have fixed the GH reading.

Tomorrow, I'll fix the VSS, and I'll make sure to update the wiki with calibration settings once I have them.

Damn fine product, thanks to all the developers!
__________________
  Reply With Quote
Old 01-01-2010, 08:56 PM   #3 (permalink)
in tents
 
dennyt's Avatar
 
Join Date: Dec 2009
Location: Seattle, WA, USA
Posts: 158

The Adventure Wagon - '94 Subaru Loyale Wagon 4x4
Subaru
90 day: 33.43 mpg (US)

Electro-Monkey - '11 Surly Karate Monkey BMC V2S Front Hub Motor
90 day: 694.1 mpg (US)
Thanks: 31
Thanked 30 Times in 22 Posts
Success! Still working on calibration settings. 9000 cts/mi seems about right for the VSS, no idea on the fuel setting.

Installed a vacuum gage and an injector kill switch while I was at it. Yeeha!

__________________

Last edited by dennyt; 01-01-2010 at 09:13 PM..
  Reply With Quote
Old 09-10-2011, 02:56 PM   #4 (permalink)
Smeghead
 
Join Date: Oct 2009
Location: South Central AK
Posts: 933

escort - '99 ford escort sport
90 day: 42.38 mpg (US)

scoobaru - '02 Subaru Forester s
90 day: 28.65 mpg (US)
Thanks: 32
Thanked 145 Times in 97 Posts
Where did you tap into VSS and injector signals, what settings for fuel and vss signals. I just picked up an 88 SPFI Loyale (GL) and would like to install my guino into it.
__________________

Learn from the mistakes of others, that way when you mess up you can do so in new and interesting ways.

One mile of road will take you one mile, one mile of runway can take you around the world.
  Reply With Quote
Old 09-10-2011, 11:02 PM   #5 (permalink)
in tents
 
dennyt's Avatar
 
Join Date: Dec 2009
Location: Seattle, WA, USA
Posts: 158

The Adventure Wagon - '94 Subaru Loyale Wagon 4x4
Subaru
90 day: 33.43 mpg (US)

Electro-Monkey - '11 Surly Karate Monkey BMC V2S Front Hub Motor
90 day: 694.1 mpg (US)
Thanks: 31
Thanked 30 Times in 22 Posts
I ended up abandoning the MPGuino because this car has a peak-and-hold injector, which isn't supported yet. Here is a thread about that. There is hope... if you want to build a signal conditioning circuit or rewrite the code.
http://ecomodder.com/forum/showthrea...or-6841-4.html

I tapped directly into the injector wire at the plug near the throttle body. I can't say if it was on the + or - lead, because I couldn't distinguish colors on the wires there.

For VSS I tapped into the yellow wire with the red stripe on the harness heading up to the instrument cluster. Check out page 155 of this PDF: http://jdfinley.com/downloads/Subaru...anualPart2.pdf
__________________
  Reply With Quote
Old 09-11-2011, 12:21 PM   #6 (permalink)
Smeghead
 
Join Date: Oct 2009
Location: South Central AK
Posts: 933

escort - '99 ford escort sport
90 day: 42.38 mpg (US)

scoobaru - '02 Subaru Forester s
90 day: 28.65 mpg (US)
Thanks: 32
Thanked 145 Times in 97 Posts
Thanks

__________________

Learn from the mistakes of others, that way when you mess up you can do so in new and interesting ways.

One mile of road will take you one mile, one mile of runway can take you around the world.
  Reply With Quote
Reply  Post New Thread


Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
MPGuino release one workspace dcb OpenGauge / MPGuino FE computer 1060 09-27-2016 11:56 PM
MPGuino rebooting and freezing also... Power issue? tygertec OpenGauge / MPGuino FE computer 28 04-17-2011 05:05 PM
Super MPGuino? gtkid2002 OpenGauge / MPGuino FE computer 97 02-06-2011 01:39 PM
All default values for MPGuino? JohnNeiferd OpenGauge / MPGuino FE computer 2 09-16-2009 01:24 PM
Mpguino 98 subaru legacy Csht OpenGauge / MPGuino FE computer 0 11-16-2008 05:39 PM



Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Content Relevant URLs by vBSEO 3.5.2
All content copyright EcoModder.com